php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37849 Can't Access Network Files
Submitted: 2006-06-19 16:59 UTC Modified: 2006-07-26 23:51 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: anelson at axiom-capital dot com Assigned:
Status: Not a bug Package: GetImageSize related
PHP Version: 5.1.4 OS: Windows 2000
Private report: No CVE-ID: None
 [2006-06-19 16:59 UTC] anelson at axiom-capital dot com
Description:
------------
getimagesize() allows me to access files from my C drive but over the local intranet I can't.  I know the path is correct because it runs from the command prompt.  I have the appropriate permissions (full control) of the file. 

Reproduce code:
---------------
Warning: getimagesize(\\192.168.2.2\deals\04 Deals CLOSED\Interior\Mvc-003f.jpg) 

[function.getimagesize]: failed to open stream: Permission denied in C:\wamp\www\Pictures\report.php on line 135

Expected result:
----------------
I expect this function to return an array of 4 values.

Actual result:
--------------
The result is an empty value

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-07-26 23:51 UTC] sniper@php.net
Read the error message couple of times and act accordingly. This has nothing to do with PHP and there is not bug here.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Apr 22 16:01:25 2019 UTC