php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #37521 bug #29443 is still present
Submitted: 2006-05-19 16:15 UTC Modified: 2006-05-20 19:52 UTC
From: maia_good at hotmail dot com Assigned:
Status: Not a bug Package: GetImageSize related
PHP Version: 5.1.4 OS: Windows_NT
Private report: No CVE-ID: None
 [2006-05-19 16:15 UTC] maia_good at hotmail dot com
Description:
------------
Bug #29443 is still present in 5.1.4 despite being closed as of 30 Jul 2004.
[29 Jul 2004 3:00pm UTC] fredb86 at hotmail dot com

If you do a getimagesize of an MPEG-4 video file, getimagesize reports
the MIME type as an image file: 
[mime] => image/vnd.wap.wbmp
Sample video file is here:
http://sashimikid.spymac.net/junk.mov

[30 Jul 2004 3:10am UTC] iliaa@php.net

This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

Reproduce code:
---------------
print_r(getimagesize('junk.mov'));


Expected result:
----------------
Array
(
    [0] => 570221
    [1] => 100
    [2] => 15
    [3] => width="570221" height="100"
    [mime] => video/quicktime
)

OR

Array
(
    [0] => 570221
    [1] => 100
    [2] => 15
    [3] => width="570221" height="100"
    [mime] => video/mp4v-es 
)

Actual result:
--------------
Array
(
    [0] => 570221
    [1] => 100
    [2] => 15
    [3] => width="570221" height="100"
    [mime] => image/vnd.wap.wbmp
)



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-05-20 19:52 UTC] iliaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

The function is not made to analyize mpeg files, the only way 
it can is because mpeg4 files store data in jpeg format and 
getimagesize() picks up on that. 
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Jul 21 08:01:25 2019 UTC