php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36547 SOAP problem with WSDL, not importing types correctly
Submitted: 2006-02-27 19:38 UTC Modified: 2006-03-10 12:58 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: invrnrv at gmail dot com Assigned: dmitry (profile)
Status: Not a bug Package: SOAP related
PHP Version: 5.1.2 OS: fedora core
Private report: No CVE-ID: None
 [2006-02-27 19:38 UTC] invrnrv at gmail dot com
Description:
------------
when importing types, as in

<types>
  <import schemaLocation="blah" namespace="blah"/>
<types>

it seems like the php soap extension doesn't import the xsd file correctly.

When i make a request, the soap request body shows:

 <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">

<SOAP-ENV:Body><body> ....

instead of the expected:

 <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">

<SOAP-ENV:Body><ComplexTypeName xmlns="blah> ....

This doesn't appear to be a problem with other libraries, such as NuSoap.

Is this a bug / upcoming feature?

 - Jae



Expected result:
----------------
 <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">

<SOAP-ENV:Body><ComplexTypeName xmlns="blah> ....

Actual result:
--------------
 <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">

<SOAP-ENV:Body><body> ....

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-28 09:26 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.1-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5.1-win32-latest.zip


 [2006-03-03 18:47 UTC] invrnrv at gmail dot com
I cannot post a followup to this because the bugtracker says that I am "spamming" the system.

basically, the suggestion below didn't fix anything.
 [2006-03-03 18:53 UTC] invrnrv at gmail dot com
I simply built the cgi binary with --enable-soap option.

My WSDL file:
 [2006-03-03 18:53 UTC] invrnrv at gmail dot com
<?xml version="1.0" encoding="UTF-8"?>
<definitions xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
             xmlns="http://schemas.xmlsoap.org/wsdl/ "
             xmlns:xs="http://www.w3.org/2001/XMLSchema"
 [2006-03-03 18:54 UTC] invrnrv at gmail dot com
xmlns:tns="http://blahblah"
             targetNamespace=" http://blahblah">
   <types>
         <xs:import namespace="http://blahblah" schemaLocation="blah.xsd"/>
   </types>

...
 [2006-03-03 18:54 UTC] invrnrv at gmail dot com
This WSDL file works fine with PHP5 if I manually copy the contents of blah.xsd into the <types> element (minus the first line, <?xml... )

I have tried several schemaLocation formats:

schemaLocation="blah.xsd"
schemaLocation="http://correct-location/blah.xsd"
schemaLocation="/localdirectory/blah.xsd"

none of them work.

 - Jae
 [2006-03-10 12:58 UTC] dmitry@php.net
This is not an ext/soap bug, but probably a user's mistake.

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Apr 22 16:01:25 2019 UTC