php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36446 GetImageSize return "Connection Refused Failed to open stream"
Submitted: 2006-02-18 19:18 UTC Modified: 2006-02-18 23:18 UTC
From: rodolfocaminiti at msn dot com Assigned:
Status: Not a bug Package: GetImageSize related
PHP Version: 5.1.2 OS: Fedora
Private report: No CVE-ID: None
 [2006-02-18 19:18 UTC] rodolfocaminiti at msn dot com
Description:
------------
GetImageSize return "Connection Refused Failed to open stream" when the file is stored in the database mysql. This error isn't present in all php4.

The Img is showed but if I wish to have the size php by another file that call the img throgh the script below show this error:

Warning: getimagesize(http://www.nomesito.it/screen.php?Id=1) [function.getimagesize]: failed to open stream: Connection refused in /home/web/www.vincity.it/website/modules/screenshots/resize.php on line 105


Reproduce code:
---------------
The Img is called by a similar script (screen.php):
<?
$query  = "SELECT DatiBinari, Type FROM ".$config['db_tbl_prefix']."screenshots WHERE Id = '" . $_GET["Id"] . "'";
$select = @mysql_query($query) or die("Query fallita !");

$result = @mysql_fetch_array($select);
$data   = $result["DatiBinari"];
$type   = $result["Type"];

Header("Content-type: $type");
echo $data;
?>



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-02-18 23:18 UTC] mike@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jun 27 06:01:31 2019 UTC