php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36192 Executing sudo command
Submitted: 2006-01-28 14:12 UTC Modified: 2006-01-28 14:23 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: zajec5 at op dot pl Assigned:
Status: Not a bug Package: Systems problem
PHP Version: Irrelevant OS: Linux Mandriva 2006.0
Private report: No CVE-ID: None
 [2006-01-28 14:12 UTC] zajec5 at op dot pl
Description:
------------
PHP can't properly execute command "sudo" in Linux. Commands used in this method look to work fine, but I can't receive communique of system.

Reproduce code:
---------------
<?php
echo system('sudo somenotexistingcmd');
echo shell_exec('sudo somenotexistingcmd');
passthru('sudo somenotexistingcmd');
?>

Expected result:
----------------
Output like this:
sudo: somenotexistingcmd: command not found

Actual result:
--------------
No output.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-28 14:23 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jul 23 22:01:28 2019 UTC