php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36040 EXIF fails to load on fresh winxp sp2
Submitted: 2006-01-17 01:32 UTC Modified: 2006-01-17 05:34 UTC
From: djconfirm at yahoo dot com Assigned:
Status: Not a bug Package: EXIF related
PHP Version: 4.4.2 OS: win xp sp2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: djconfirm at yahoo dot com
New email:
PHP Version: OS:

 

 [2006-01-17 01:32 UTC] djconfirm at yahoo dot com
Description:
------------
Fresh install of WIN XP, SP2.
Apache 2.0.54
php 4.4.2
trying to configure to run php_EXIF.dll.
using php.ini-recommended except that extension php_exif.dll is enabled.

Apache fails to start.
comment extension php_exif.dll and all is well.
I note that php_exif.dll [using depends.exe] references MSJAVA and MPR.DLL and that MPR.dll [dley load load dependendency] shows unresolved import due to missing import function.

I provided a copy of MSJAVA.DLL [only that DLL and not entire install] and Apache still crashes.

php 4.4.0 worked previously, but java was probably on this system at that time. This system is fresh, java not installed and it has been updated to latest win xp critical updates.

Seems like php_exif should work in this case. MPR.DLL version 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)

Thanks,
darrell duffy


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-17 01:34 UTC] tony2001@php.net
Windows users must enable both the php_mbstring.dll and php_exif.dll DLL's in php.ini. The php_mbstring.dll DLL must be loaded before the php_exif.dll DLL so adjust your php.ini accordingly.

http://php.net/exif
 [2006-01-17 05:34 UTC] djconfirm at yahoo dot com
Sorry.. I thought I read install docs carefully... Missed the php_mbstring.dll dependency and seeing DLL dependencies in php_exif.dll sent me off in wrong direction. All is working well after activing php_mbstring.dll first.

Thanks,
djd
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Jun 20 04:01:45 2018 UTC