php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #36035 COM function can't call a registered DLL
Submitted: 2006-01-16 21:39 UTC Modified: 2006-01-26 11:51 UTC
Votes:4
Avg. Score:5.0 ± 0.0
Reproduced:4 of 4 (100.0%)
Same Version:4 (100.0%)
Same OS:4 (100.0%)
From: reha at bilgiparki dot com Assigned: wez (profile)
Status: Not a bug Package: COM related
PHP Version: 5.1.2 OS: Windows 2003
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: reha at bilgiparki dot com
New email:
PHP Version: OS:

 

 [2006-01-16 21:39 UTC] reha at bilgiparki dot com
Description:
------------
Php 5.1.2 COM function can't call a registered DLL into server, but it is working correctly on Php 5.0.5

Reproduce code:
---------------
<?
$pay = new COM("epayapi.payment") or die("BilgiPARKI POS hatal?"); 
?>

Expected result:
----------------
There shouldn't be return any error

Actual result:
--------------
Fatal error: Uncaught exception 'com_exception' with message 'Error [0x80020003] Member not found. ' in F:\www\secure.bilgiparki.com\test.php:2 Stack trace: #0 F:\Hosts\secure.bilgiparki.com\test.php(2): unknown() #1 {main} thrown in D:\www\secure.bilgiparki.com\test.php on line 2


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2006-01-16 21:42 UTC] tony2001@php.net
Assigned to the maintainer.
 [2006-01-24 14:42 UTC] elgrandidou at liiri dot com
Same problem:
Php 5.1.2 COM function can't call a registered DLL into server, but it is working correctly on Php 5.0.5.

Same error:
Fatal error: Uncaught exception 'com_exception' with message 'Error [0x80020003] Member not found.'

I use the COM object of hMailServer 4.2:
http://hmailserver.com/?page=show_mirrors&downloadid=108
 [2006-01-26 11:51 UTC] rrichards@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Dupe of bug #35954
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Nov 27 15:05:53 2022 UTC