php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #35742 inconsistency in tidy tag name
Submitted: 2005-12-20 10:10 UTC Modified: 2010-12-20 10:03 UTC
From: humbads at alum dot mit dot edu Assigned:
Status: Closed Package: Tidy (PECL)
PHP Version: Irrelevant OS: all
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: humbads at alum dot mit dot edu
New email:
PHP Version: OS:

 

 [2005-12-20 10:10 UTC] humbads at alum dot mit dot edu
Description:
------------
In the Tidy constants page, http://cvs.php.net/viewcvs.cgi/phpdoc/en/reference/tidy/constants.xml?view=markup

it defines a constant called: TIDY_TAG_NOSAFE

However, in the CVS of tidy.c, the line says:

TIDY_TAG_CONST(NOSAVE);

So when I try to use the TIDY_TAG_NOSAFE constant, I get an error saying it doesn't exist.


Reproduce code:
---------------
// enable tidy extension
print TIDY_TAG_NOSAFE;

Expected result:
----------------
The documentation needs to be corrected to say, TIDY_TAG_NOSAVE instead of TIDY_TAG_NOSAFE.

NOSAVE is the correct tag name. See:
http://www.htmlcodetutorial.com/images/_IMG_NOSAVE.html


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-20 15:48 UTC] nlopess@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.
 [2010-12-20 10:03 UTC] jani@php.net
-Package: Documentation problem +Package: Tidy -Assigned To: +Assigned To: jani
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 19:03:37 2021 UTC