php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35681 xmlwriter has non-ansi comments
Submitted: 2005-12-15 14:50 UTC Modified: 2007-08-23 14:04 UTC
From: to2958 at sbc dot com Assigned:
Status: Closed Package: XML Writer
PHP Version: 5CVS-2005-12-14 (snap) OS: AIX 4.3.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: to2958 at sbc dot com
New email:
PHP Version: OS:

 

 [2005-12-15 14:50 UTC] to2958 at sbc dot com
Description:
------------
I obtained the snapshot 200512141330 to see about other problems and run into a new problem with compiling the ext/xmlwriter.c. It doesn't look like that was even part of the stable 5.1.1. I'm running with VAC 4.4.0.3. I got this on make:
"/store/php5.1-200512141330/TSRM/tsrm_config_common.h", line 23.1: 1506-224 (I) 
Incorrect #pragma ignored.
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1633.17: 1506-0
46 (S) Syntax error.
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1633.26: 1506-0
45 (S) Undeclared identifier not.
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1643.9: 1506-27
6 (S) Syntax error: possible missing 'while'?
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1663.9: 1506-27
6 (S) Syntax error: possible missing 'while'?
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1670.9: 1506-27
6 (S) Syntax error: possible missing 'while'?
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1684.1: 1506-27
6 (S) Syntax error: possible missing 'while'?
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1702.17: 1506-0
46 (S) Syntax error.
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1702.57: 1506-0
45 (S) Undeclared identifier xmlwriter.
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1714.9: 1506-27
6 (S) Syntax error: possible missing 'while'?
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1720.9: 1506-27
6 (S) Syntax error: possible missing 'while'?
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1735.1: 1506-27
6 (S) Syntax error: possible missing 'while'?
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1769.21: 1506-0
45 (S) Undeclared identifier force_string.
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1790.1: 1506-27
6 (S) Syntax error: possible missing 'while'?
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1798.1: 1506-27
6 (S) Syntax error: possible missing 'while'?
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1806.1: 1506-27
6 (S) Syntax error: possible missing 'while'?
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1812.93: 1506-0
45 (S) Undeclared identifier module_number.
"/store/php5.1-200512141330/ext/xmlwriter/php_xmlwriter.c", line 1821.16: 1506-0
68 (S) Operation between types "void" and "int" is not allowed.
make: 1254-004 The error code from the last command is 1.

It looks like the comment of // is causing problems a patch is included.

This is similiar to other bugs except none are for this file. Mentioned bugs are 1424, 8345, 1267. 

Reproduce code:
---------------
Patch:
--- php_xmlwriter.c.orig        Wed Dec 14 10:15:16 2005
+++ php_xmlwriter.c     Wed Dec 14 10:27:23 2005
@@ -1630,7 +1630,7 @@
 
 #ifdef ZEND_ENGINE_2
        if (this) {
-               // We do not use XMLWRITER_FROM_OBJECT, xmlwriter init function 
here
+               /* We do not use XMLWRITER_FROM_OBJECT, xmlwriter init function 
here */
                ze_obj = (ze_xmlwriter_object*) zend_object_store_get_object(thi
s TSRMLS_CC); 
        }
 #endif
@@ -1699,7 +1699,7 @@
 
 #ifdef ZEND_ENGINE_2
        if (this) {
-               // We do not use XMLWRITER_FROM_OBJECT, xmlwriter init function 
here
+               /* We do not use XMLWRITER_FROM_OBJECT, xmlwriter init function 
here */
                ze_obj = (ze_xmlwriter_object*) zend_object_store_get_object(thi
s TSRMLS_CC); 
        }
 #endif


Expected result:
----------------
I expected it to compile everything.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-12-15 14:58 UTC] tony2001@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Nov 29 12:03:14 2021 UTC