php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #35058 server abend using spl_autoload and friends
Submitted: 2005-11-01 21:16 UTC Modified: 2005-11-01 22:37 UTC
From: boots@php.net Assigned:
Status: Not a bug Package: SPL related
PHP Version: 5.1.0RC4 OS: windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: boots@php.net
New email:
PHP Version: OS:

 

 [2005-11-01 21:16 UTC] boots@php.net
Description:
------------
Similar to http://bugs.php.net/bug.php?id=34216 I am experiencing intermitent server abends while trying to integrate some of the new spl_autoload_* functionality in a custom application on apache 1.3.33. In particular, I am using spl to register a static class method that implements its own polymorphic autoload behaviours. The custom class loader is known to work well if called directly from __autoload.

It also appears that all documentation for (and mention of) spl_autoload_* has disappeared. Is this still intended for 5.1 and/or are their plans to integrate this into the engine -- where it belongs?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-11-01 22:37 UTC] sniper@php.net
How did you get a @php.net address? Haven't you got ANY idea how to report? (see: http://bugs.php.net/how-to-report.php)

Try come up with a PERFECT reproducing script or leave this report as bogus what it now is.


 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC