php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34778 DirectoryIterator::getType is inconsistent with filetype()
Submitted: 2005-10-07 13:41 UTC Modified: 2005-10-12 22:07 UTC
From: richard dot quadling at bandvulc dot co dot uk Assigned: helly (profile)
Status: Not a bug Package: SPL related
PHP Version: 5.0.5 OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: richard dot quadling at bandvulc dot co dot uk
New email:
PHP Version: OS:

 

 [2005-10-07 13:41 UTC] richard dot quadling at bandvulc dot co dot uk
Description:
------------
I'm using SPL RecursiveIteratorIterator, CachingRecursiveIterator and RecursiveDirectoryIterator to get ALL the files in a directory structure.

Some of the files are being identied as directories when using DirectoryIterator::getType() and comparing this to the result of filetype().



Reproduce code:
---------------
<?php
class class_DirectoryWalker extends RecursiveIteratorIterator
	{
	function __construct($path)
		{
		parent::__construct(new CachingRecursiveIterator(new RecursiveDirectoryIterator($path), CIT_CALL_TOSTRING | CIT_CATCH_GET_CHILD), 1);
		}

	function __call($func, $params)
		{
		return call_user_func_array(array($this->getSubIterator(), $func), $params);
		}
	}

$objDIR = new class_DirectoryWalker('M:/Datastore');

foreach($objDIR as $sKey => &$objValue)
	{
	echo filetype($sKey) . ' ' . $objValue->getType() . " $sKey\n";
	}
?>

Expected result:
----------------
dir dir M:/Datastore/Bandvulc Department Desktops
dir dir M:/Datastore/Bandvulc Department Desktops/Accounts
file file M:/Datastore/Bandvulc Department Desktops/Accounts/Shortcut to ECDL.lnk
dir dir M:/Datastore/Bandvulc Department Desktops/Bandvulc Tyre Contracts
file file M:/Datastore/Bandvulc Department Desktops/Bandvulc Tyre Contracts/Bandvulc Tyre Contracts.lnk
file file M:/Datastore/Bandvulc Department Desktops/Bandvulc Tyre Contracts/Shortcut to Salvesen Europe Contacts.lnk
file file M:/Datastore/Bandvulc Department Desktops/Bandvulc Tyre Contracts/Shortcut to Sinead Williams on bandsbs.lnk
file file M:/Datastore/Bandvulc Department Desktops/Bandvulc Tyre Contracts/Shortcut to Strike Rates 2005.lnk
dir dir M:/Datastore/Bandvulc Department Desktops/Bandvulc Tyre Contracts/Unused Desktop Shortcuts
file file M:/Datastore/Bandvulc Department Desktops/Bandvulc Tyre Contracts/Unused Desktop Shortcuts/Access Accounts (btc v1).lnk
file file M:/Datastore/Bandvulc Department Desktops/Bandvulc Tyre Contracts/Unused Desktop Shortcuts/Access Accounts (btc v2).lnk


Actual result:
--------------
dir dir M:/Datastore/Bandvulc Department Desktops
dir dir M:/Datastore/Bandvulc Department Desktops/Accounts
file dir M:/Datastore/Bandvulc Department Desktops/Accounts/Shortcut to ECDL.lnk
dir dir M:/Datastore/Bandvulc Department Desktops/Bandvulc Tyre Contracts
file file M:/Datastore/Bandvulc Department Desktops/Bandvulc Tyre Contracts/Bandvulc Tyre Contracts.lnk
file file M:/Datastore/Bandvulc Department Desktops/Bandvulc Tyre Contracts/Shortcut to Salvesen Europe Contacts.lnk
file file M:/Datastore/Bandvulc Department Desktops/Bandvulc Tyre Contracts/Shortcut to Sinead Williams on bandsbs.lnk
file dir M:/Datastore/Bandvulc Department Desktops/Bandvulc Tyre Contracts/Shortcut to Strike Rates 2005.lnk
dir dir M:/Datastore/Bandvulc Department Desktops/Bandvulc Tyre Contracts/Unused Desktop Shortcuts
file file M:/Datastore/Bandvulc Department Desktops/Bandvulc Tyre Contracts/Unused Desktop Shortcuts/Access Accounts (btc v1).lnk
file file M:/Datastore/Bandvulc Department Desktops/Bandvulc Tyre Contracts/Unused Desktop Shortcuts/Access Accounts (btc v2).lnk


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-10-07 14:05 UTC] richard dot quadling at bandvulc dot co dot uk
I altered the code just to show those that are different ...

<?php
class class_DirectoryWalker extends RecursiveIteratorIterator
	{
	function __construct($path)
		{
		parent::__construct(new CachingRecursiveIterator(new RecursiveDirectoryIterator($path), CIT_CALL_TOSTRING | CIT_CATCH_GET_CHILD), 1);
		}

	function __call($func, $params)
		{
		return call_user_func_array(array($this->getSubIterator(), $func), $params);
		}
	}

$objDIR = new class_DirectoryWalker('M:/Datastore');

foreach($objDIR as $sKey => &$objValue)
	{
	if (filetype($sKey) != $objValue->getType())
		{
		echo filetype($sKey) . ' ' . $objValue->getType() . " $sKey\n";
		}
	}
?>

and get things like ...

dir file M:/Datastore/Bandvulc Department Desktops/Sales/bij1100
file dir M:/Datastore/Bandvulc Department Desktops/Sales/bij1100/win2k_xp/english/hpzvip09.dl_

Here we see a directory (filetype()) which the next line is a file within that directory and that line is being shown as a directory when in fact it is obviously a folder.
 [2005-10-07 20:17 UTC] helly@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Since you are using a CachingIterator and access the type through it the result is expected.

What happens is that the Caching iterator aggrgates the DirectoryIterator. So when you access a value from a method of the Directory iterator it is executed on the DirectoryIteraotr. But the DirectoryIteraotr has already changed it\'s state.

To solve this issue, you would need to cache all the information by deriving the CachingIterator.
 [2005-10-11 14:53 UTC] richard dot quadling at bandvulc dot co dot uk
What I don't understand is why the state is incorrect only on SOME of the results and not all the results.

Or am I doing the whole thing wrong?

Is there a better set of user documentation for these classes. I get very confused. I shouldn't. I've been doing this for long enough. But I do. I'm getting old. Nearly 40 you know. So, be nice to the old man.

I want to use OOP to get all the files and directories from a start point. I also want to add a filter to only return certain files based upon their extension. I don't know the correct way to combine the different classes.

Sorry.
 [2005-10-11 15:12 UTC] richard dot quadling at bandvulc dot co dot uk
Ok (I didn't understand the answer as I don't know why the caching should have any difference).

I think I found my problem.

<?php
class class_DirectoryWalker extends RecursiveIteratorIterator
	{
	function __construct($path)
		{
		parent::__construct(new CachingRecursiveIterator(new RecursiveDirectoryIterator($path), CIT_CALL_TOSTRING | CIT_CATCH_GET_CHILD), 1);
		}

	function __call($func, $params)
		{
		return call_user_func_array(array($this->getSubIterator(), $func), $params);
		}
	}

$objDIR = new class_DirectoryWalker('C:/test/');

$iTotal = 0;
$iRight = 0;
$iWrong = 0;
foreach($objDIR as $sKey => $objValue)
	{
	++$iTotal;
	echo $iTotal . ' ' . filetype($sKey) . ' ' . $objValue->getType() . ' ' . $sKey . ' ' . $objValue . "\n";
	if (filetype($sKey) != $objValue->getType())
		{
		++$iWrong;
		}
	else
		{
		++$iRight;
		}
	}
echo "Total : $iTotal\nRight : $iRight\nWrong : $iWrong\n";
?>

The directory test contains 1 file.

1 file dir C:/test/file1.txt Object id #3
Total : 1
Right : 0
Wrong : 1

This implies that the foreach() mechanism returns the current item for a key but the next entry for the value.

Which is very much NOT what I would expect. I would expect the key to be the filename (as it is) and the value to be the object representing the filename.

The question that comes from this is how do I get the object which is the FIRST file?

Richard.
 [2005-10-11 20:14 UTC] helly@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

As i explained there is no error in PHP.

This is actually a 30cm problem.
 [2005-10-12 12:03 UTC] richard dot quadling at bandvulc dot co dot uk
What? A 30cm problem? What does that mean?

In plain english, why is this not a bug?

You understand this domain very well. I don't. At least tell me why this is not correct. Why should the last example I supplied be considered CORRECT? It does not give expected results, there is no documentation on the class and so any behaviour is valid. Is that why?

Richard.
 [2005-10-12 22:07 UTC] helly@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Please do not reopen this bug. THERE IS NO BUG. You are turning the bug database into a mess.

And i explained it already:

<quote>
What happens is that the Caching iterator aggrgates the DirectoryIterator. So when you access a value from a method of the Directory iterator it is executed on the DirectoryIteraotr. But the DirectoryIteraotr has already changed it's state.

To solve this issue, you would need to cache all the information by deriving the CachingIterator.
</quote>

class MyDirectoryIterator
{
  function current()
  {
    return $this->getFilename();
    // the implementation in DirectoryIterator does
    // return $this;
  }
}
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC