php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34560 preg_replace strips double backslashes from second argument
Submitted: 2005-09-20 12:53 UTC Modified: 2005-09-20 13:06 UTC
From: astax dot t at gmail dot com Assigned:
Status: Not a bug Package: PCRE related
PHP Version: 4.4.0 OS: Debian
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: astax dot t at gmail dot com
New email:
PHP Version: OS:

 

 [2005-09-20 12:53 UTC] astax dot t at gmail dot com
Description:
------------
preg_replace strips double backslashes from the second passed argument, but keeps all other backslashes

Reproduce code:
---------------
$var = "a\\\\b\\c\\\"";  # this is a string a\\b\c\"
$subj = "this is a {sample} text";
echo preg_replace("/\{sample\}/", $var, $subj);


Expected result:
----------------
this is a a\\b\c\" text

Actual result:
--------------
this is a a\b\c\" text

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-09-20 13:06 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 17:05:44 2022 UTC