php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34070 PHP Startup: Unable to load dynamic library '/php_mysql.dll'
Submitted: 2005-08-10 16:27 UTC Modified: 2010-12-20 11:56 UTC
From: mikerob818 at cs dot com Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 5.0.4 OS: Windows 98
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mikerob818 at cs dot com
New email:
PHP Version: OS:

 

 [2005-08-10 16:27 UTC] mikerob818 at cs dot com
Description:
------------
Error message when try to run hello.php under PWS:

PHP Startup: Unable to load dynamic library '/php_mysql.dll'- One of the library files needed to run this application can not be found.

The checklist below is based on PHP Manual.  If the manual is missing instructions, please provide.

Thanks,

Robin
*******************
Description
Manual Installation:
Download zip binary distribution from downloads page
Website: http://www.php.net/downloads.php

Description
Microsoft 98/NT :
Download latest version of Microsoft Data Access Components (MDAC) for your
platform
Website: http://msdn.microsoft.com/data/

Description
Extract distribution file into c:\php

Description
Add c:\php to PATH by editing autoexec.bat file

path C:\WINDOWS;C:\WINDOWS\COMMAND;C:\php

Description
Download PHP extensions into c:\php5
Website: http://www.php.net/downloads.php

Description
Place php5activescript.dll in c:\php
Register dll with DOS command:
cd c:\php
regsvr32 php5activescript.dll
(regsvr32.exe was copied from c:\Windows\System\inetsrv)

Message: DllRegisterServer in php5activescript.dll succeeded

Description
To test if ActiveScript working: create test.wsf in c:\php
Double click file
If receive little window with "Hello World!", you're done

Description
Set up valid configuration file for php:
php.ini-recommended saved as php.ini

Description
ActiveScript doesn't use php.ini file
Create php-activescript.ini and place it in c:\php

Description
CGI users must set the cgi.force_redirect PHP directive to 0
in php.ini
in php-activescript.ini

Description
In php.ini
php-activescript.ini

check these values:
doc_root = c:\inetput\wwwroot
extension_dir = "./"

Description
PWS 4 does not support ISAPI, only PHP CGI should be used

Edit the pws-php5cgi.reg file in c:\php
".php"="c:\\php\\php-cgi.exe"
double click to merge registry file into system

In Personal Web Manager:*
View > Advanced > Edit Properties
Check box Execute

*Note: It appears that the PHP manual is incorrect. This manual states the
following:

In the PWS Manager, right click on a given directory you want to add PHP
support to, and select Properties. Check the 'Execute' checkbox, and
confirm.


Description
The default location PHP searches for extensions is c:\php5

In php.ini
php-activescript.ini

kept default setting for extension_dir

Description
Enable the extensions
In php.ini
php-activescript.ini

Done by deleting leading ; from extension you want to load

Removed ; from beginning of:
extension=php_mysql.dll

Description
Create hello.php and put in web server's root directory (document_root). Use
browser to access locally with:

http://localhost/hello.php

Code:

<html>
<head>
<title>PHP Test</title>
</head>
<body>
<?php echo '<p>Hello World</p>'; ?>
</body>
</html>

Got error message:
PHP Startup: Unable to load dynamic library '/php_mysql.dll'
One of the library files needed to run this application can not be found



Files under c:\php

fdftk.dll, fribidi.dll, gds32.dll, go-pear.bat, install.txt, libeay32.dll,
libmhash.dll, libmysql.dll, license.txt, msql.dll, news.txt, ntwdblib.dll,
php.exe, php.gif, php.ini, php.ini-dis, php.ini-recommended, php_mysql.dll,
php5activescript.dll, php5apache.dll, php5apache_hooks.dll, php5apache2.dll,
php5embed.lib, php5isapi.dll, php5nsapi.dll, php5ts.dll,
php-activescript..ini, php-cgi.exe, php-win.exe, pws-php5cgi.reg,
pws-php5isapi.reg, regsvr32.exe, snapshot.txt, ssleay32.dll, test.wsf,
yaz.dll

Files under c:\php\ext

php_bz2.dll, php_cpdf.dll, php_curl.dll, php_dba.dll, php_dbase.dll,
php_dbx.dll, php_dio.dll, php_exif.dll, php_fdf.dll, php_filepro.dll,
php_gd2.dll, php_gettext.dll, php_ifx.dll, php_imap.dll, php_interbase.dll,
php_ldap.dll, php_mbstring.dll, php_mcrypt.dll, php_mhash.dll,
php_mime_magic.dll, php_ming.dll, php_msql.dll, php_mysql.dll,
php_mysqli.dll, php_oci8.dll, php_openssl.dll, php_oracle.dll,
php_pgsql.dll, php_pspell.dll, php_shmop.dll, php_snmp.dll, php_soap.dll,
php_sockets.dll, php_sybase_ct.dll, php_tidy.dll, php_xmlrpc.dll,
php_xsl.dll


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-10 16:32 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 [2010-12-20 11:56 UTC] jani@php.net
-Package: Tidy +Package: Dynamic loading
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Dec 05 16:01:29 2023 UTC