php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #34041 md5() function fails
Submitted: 2005-08-08 20:32 UTC Modified: 2005-08-08 22:40 UTC
From: RVaughn at pheedo dot com Assigned:
Status: Not a bug Package: mhash related
PHP Version: 4.4.0 OS: RHEL 3.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: RVaughn at pheedo dot com
New email:
PHP Version: OS:

 

 [2005-08-08 20:32 UTC] RVaughn at pheedo dot com
Description:
------------
The md5() function in the 'mhash' fails.  Several of the 'mhash' tests in the PHP test suite fail on Red Hat Ent. 3.0 and two other tests that use the md5() call also fail because of this call although the functions/bugs they're testing are fine (as confirmed by hand.)

The mhash tests that fail:

mhash() test [ext/mhash/tests/001.phpt]
mhash_keygen_s2k() test [ext/mhash/tests/003.phpt]

The other test that fails due to md5() function usage:

php-users@php.gr.jp #16242 [ext/mbstring/tests/php_gr_jp_16242.phpt]
Bug #22414: passthru() does not read data correctly [ext/standard/tests/file/bug22414.phpt]

We had mhash-0.9.1 and mhash-devel-0.9.1 installed, which I upgraded to mhash-0.9.2-3 and mhash-devel-0.9.2-3 but this did not fix or change the output.

My configuration:

./configure 2>configure.err '--host=i386-redhat-linux' '--build=i386-redhat-linux' '--target=i386-redhat-linux-gnu' '--cache-file=../config.cache' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--enable-force-cgi-redirect' '--disable-debug' '--enable-pic' '--disable-rpath' '--enable-inline-optimization' '--with-bz2' '--with-db4=/usr' '--with-curl' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-gd' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-ncurses' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-aspell' '--with-regex=system' '--with-xml' '--with-expat-dir=/usr' '--with-dom=shared,/usr' '--with-dom-xslt=/usr' '--with-dom-exslt=/usr' '--with-xmlrpc=shared' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-bcmath' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-safe-mode' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-discard-path' '--enable-track-vars' '--enable-trans-sid' '--disable-yp' '--enable-wddx' '--without-oci8' '--with-pear=/usr/share/pear' '--with-kerberos' '--with-mysql=shared,/usr' '--with-snmp=shared,/usr' '--with-snmp=shared' '--enable-ucd-snmp-hack' '--with-unixODBC=shared' '--enable-memory-limit' '--enable-bcmath' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--enable-mcal' '--enable-mbstring=/usr/lib/php4/' '--enable-mbstr-enc-trans' '--enable-mbregex' '--with-apxs2=/usr/sbin/apxs'


Reproduce code:
---------------
The following test scripts illustrate the failures completely on RHEL 3.0:

.../ext/mhash/tests/001.phpt
.../ext/mhash/tests/003.phpt

Failure caused by md5() call:

.../ext/mbstring/tests/php_gr_jp_16242.phpt

I have modified the ext/standard/tests/file/bug22414.phpt script to call the crc32() function as well, which also fails.  You can retrieve a copy at:

http://dev.pheedo.com/temp/bug22414.phpt

It does have debugging statements (echo calls) commented out.


Expected result:
----------------
===============================================================================
/usr/local/src/Tars/php-4.4.0/ext/mhash/tests/001.phpt
===============================================================================

---- EXPECTED OUTPUT
MHASH_MD5
ok

MHASH_SHA1
ok

MHASH_HAVAL256
ok

MHASH_HAVAL192
ok

MHASH_HAVAL224
ok

MHASH_HAVAL160
ok

MHASH_RIPEMD160
ok

MHASH_GOST
ok

MHASH_TIGER
ok

MHASH_CRC32
ok

MHASH_CRC32B
ok


Actual result:
--------------
No output from either mhash test.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-08-08 22:40 UTC] sniper@php.net
They might not fail if you had mhash enabled in your build..

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 17 18:01:24 2020 UTC