php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #33426 Allow ftp_size to read 2GB+ files
Submitted: 2005-06-22 00:35 UTC Modified: 2020-02-18 08:25 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: adams at techweavers dot net Assigned: cmb (profile)
Status: Closed Package: FTP related
PHP Version: * OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: adams at techweavers dot net
New email:
PHP Version: OS:

 

 [2005-06-22 00:35 UTC] adams at techweavers dot net
Description:
------------
I am trying to get files larger then 2.1 GBytes and unfortunately it is returning interger values. If you could look into this in the next version of PHP 5.0.5 or etc... 

I would really like to see this added and so does at least 3 other php users. Like it was said before it seems this int is dated as well as the ftp_alloc takes an int or at least change it from bytes to kbytes.

I do use the FTP protocol quite a bit with my backup script and well backing up WEB servers now are larger then 2.1GB and I may have to switch over to another language.

I would really love to see this change implemented not just for the reason there are more then 2.1 GB files out there but at least update it to be Kbyte and mulitply it by 1024


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-12-30 22:55 UTC] cmb@php.net
-Package: Feature/Change Request +Package: FTP related
 [2020-02-18 04:01 UTC] carusogabriel@php.net
-Summary: ftp_size +Summary: Allow ftp_size to read 2GB+ files -Operating System: FreeBSD 4.10 +Operating System: * -PHP Version: 4.3.10 +PHP Version: *
 [2020-02-18 08:25 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2020-02-18 08:25 UTC] cmb@php.net
As of PHP 7.0.0, ftp_alloc() and supposedly the whole ftp
extension works with 64bit integers on 64bit systems.  On 32bit
systems, integers are still 32bit, but that won't change.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu May 28 01:01:26 2020 UTC