php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33183 Sybase: Unable to allocate connection record
Submitted: 2005-05-30 07:48 UTC Modified: 2005-05-30 15:35 UTC
From: clarkjohnston at comcast dot net Assigned:
Status: Not a bug Package: Sybase-ct (ctlib) related
PHP Version: 4.3.9 OS: RHEL4
Private report: No CVE-ID: None
 [2005-05-30 07:48 UTC] clarkjohnston at comcast dot net
Description:
------------
After installing php-4.3.9-3.6.src.rpm I modified the php.spec file to add --with-sybase-ct=/opt/sybase/OCS-12_5

Everything appeared to compile fine but after update installing the rpms I get the error 
'Warning: sybase_connect(): Sybase:Unable to allocate connection record.'
when attempting to run code.

I have done this before on RHEL3 and did not run into this problem.

The server is running fine and I can use isql from this server and connect to SYBASESR


%configure \
        --cache-file=../config.cache \
        --with-config-file-path=%{_sysconfdir} \
        --with-config-file-scan-dir=%{_sysconfdir}/php.d \
        --enable-force-cgi-redirect \
        --disable-debug \
        --enable-pic \
        --disable-rpath \
        --enable-inline-optimization \
        --with-bz2 \
        --with-db4=%{_prefix} \
        --with-curl \
        --with-exec-dir=%{_bindir} \
        --with-freetype-dir=%{_prefix} \
        --with-png-dir=%{_prefix} \
        --with-gd=shared \
        --enable-gd-native-ttf \
        --without-gdbm \
        --with-gettext \
        --with-ncurses=shared \
        --with-gmp \
        --with-iconv \
         --with-jpeg-dir=%{_prefix} \
        --with-openssl \
        --with-png \
        --with-pspell \
        --with-xml \
        --with-expat-dir=%{_prefix} \
        --with-dom=shared,%{_prefix} \
        --with-dom-xslt=%{_prefix} --with-dom-exslt=%{_prefix} \
        --with-xmlrpc=shared \
        --with-pcre-regex=%{_prefix} \
        --with-zlib \
        --with-layout=GNU \
        --enable-bcmath \
        --enable-exif \
        --enable-ftp \
        --enable-magic-quotes \
        --enable-sockets \
        --enable-sysvsem \
        --enable-sysvshm \
        --enable-track-vars \
        --enable-trans-sid \
        --enable-yp \
        --enable-wddx \
   
--with-pear=/usr/share/pear \
        --with-imap=shared --with-imap-ssl \
        --with-kerberos \
        --with-ldap=shared \
        --with-mysql=shared,%{_prefix} \
        %{?_with_oci8:--with-oci8-instant-client=shared} \
        %{?_with_mssql:--with-mssql=shared} \
        %{?_with_mhash:--with-mhash=shared} \
        --with-pgsql=shared \
        --with-snmp=shared,%{_prefix} \
        --with-snmp=shared \
        --enable-ucd-snmp-hack \
        --with-unixODBC=shared,%{_prefix} \
        --with-sybase-ct=/opt/sybase/OCS-12_5 \
        --enable-memory-limit \
        --enable-shmop \
        --enable-calendar \
        --enable-dbx \
        --enable-dio \
        --enable-mbstring=shared --enable-mbstr-enc-trans \
        --enable-mbregex \
        --with-mime-magic=%{_datadir}/file/magic.mime \
        $* || tail -300 config.log


Reproduce code:
---------------
script:
        $server="SYBASESR";
        $user="sa";
        $pass="";
        $con =sybase_connect($server,$user, $pass);




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-30 15:35 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Aug 22 04:01:26 2019 UTC