php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33044 My Soap Server programmed by PHP can't get variable $HTTP_RAW_POST_DATA
Submitted: 2005-05-17 07:38 UTC Modified: 2005-05-17 08:59 UTC
From: liyong at nenu dot edu dot cn Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 5.0.3 OS: Win2K Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: liyong at nenu dot edu dot cn
New email:
PHP Version: OS:

 

 [2005-05-17 07:38 UTC] liyong at nenu dot edu dot cn
Description:
------------
I write a wsdl file, i specify a php file as soap address.
But in this php file, $HTTP_RAW_POST_DATA variable is not set ; and php://input can't read also.
I had open "always_populate_raw_post_data" option in "php.ini" .

this is $_SERVER:(
    [ALL_HTTP] => HTTP_ACCEPT:application/octet-stream, text/xml
HTTP_CONNECTION:Keep-Alive
HTTP_HOST:205.120.1.196
HTTP_USER_AGENT:Borland SOAP 1.1
HTTP_CONTENT_LENGTH:579
HTTP_CONTENT_TYPE:text/xml
HTTP_CACHE_CONTROL:no-cache

    [HTTPS] => off
    [SCRIPT_NAME] => /new/SoapServer.php
    [HTTP_COOKIE] => 
    [AUTH_PASSWORD] => 
    [AUTH_TYPE] => 
    [AUTH_USER] => 
    [CONTENT_LENGTH] => 579
    [CONTENT_TYPE] => text/xml
    [PATH_TRANSLATED] => D:\voiceService
    [QUERY_STRING] => 
    [REMOTE_ADDR] => 205.120.1.150
    [REMOTE_HOST] => 205.120.1.150
    [REMOTE_USER] => 
    [REQUEST_METHOD] => POST
    [SERVER_NAME] => 205.120.1.196
    [SERVER_PORT] => 80
    [SERVER_PROTOCOL] => HTTP/1.1
    [SERVER_SOFTWARE] => Microsoft-IIS/5.0
    [APPL_MD_PATH] => /LM/W3SVC/1/Root
    [APPL_PHYSICAL_PATH] => D:\voiceService    [INSTANCE_ID] => 1
    [INSTANCE_META_PATH] => /LM/W3SVC/1
    [LOGON_USER] => 
    [REQUEST_URI] => /new/SoapServer.php
    [URL] => /new/SoapServer.php
    [SCRIPT_FILENAME] => D:\voiceService\new\SoapServer.php
    [ORIG_PATH_INFO] => /new/SoapServer.php
    [PATH_INFO] => 
    [ORIG_PATH_TRANSLATED] => D:\voiceService\new\SoapServer.php
    [DOCUMENT_ROOT] => D:\voiceService
    [PHP_SELF] => /new/SoapServer.php
    [HTTP_ACCEPT] => application/octet-stream, text/xml
    [HTTP_CONNECTION] => Keep-Alive
    [HTTP_HOST] => 205.120.1.196
    [HTTP_USER_AGENT] => Borland SOAP 1.1
    [HTTP_CONTENT_LENGTH] => 579
    [HTTP_CONTENT_TYPE] => text/xml
    [HTTP_CACHE_CONTROL] => no-cache
    [argv] => Array
        (
        )

    [argc] => 0
)

Reproduce code:
---------------
this is WSDL file:
<?xml version="1.0" ?> 
<definitions xmlns="http://schemas.xmlsoap.org/wsdl/" xmlns:xs="http://www.w3.org/2001/XMLSchema" name="IcallipReturnservice" targetNamespace="http://tempuri.org/" xmlns:tns="http://tempuri.org/" xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/">
<message name="cipRetRequest">
<part name="resultcode" type="xs:unsignedInt" /> 
<part name="serialNo" type="xs:unsignedInt" /> 
</message>
<message name="cipRetResponse">
<part name="return" type="xs:boolean" /> 
</message>
<portType name="IcallipReturn">
<operation name="cipRet">
<input message="tns:cipRetRequest" /> 
<output message="tns:cipRetResponse" /> 
</operation>
</portType>
<binding name="IcallipReturnbinding" type="tns:IcallipReturn">
<soap:binding style="rpc" transport="http://schemas.xmlsoap.org/soap/http" /> 
<operation name="cipRet">
<soap:operation soapAction="urn:callipReturn-IcallipReturn#cipRet" style="rpc" /> 
<input>
<soap:body use="encoded" encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" namespace="urn:callipReturn-IcallipReturn" /> 
</input>
<output>
<soap:body use="encoded" encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" namespace="urn:callipReturn-IcallipReturn" /> 
</output>
</operation>
</binding>
<service name="IcallipReturnservice">
<port name="IcallipReturnPort" binding="tns:IcallipReturnbinding">
<soap:address location="http://205.120.1.196/new/SoapServer.php" /> 
</port>
</service>
</definitions>


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-17 08:59 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC