php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #33023 ./configure appears to hang after detecting os version
Submitted: 2005-05-13 00:12 UTC Modified: 2005-05-30 14:59 UTC
From: terry dot gill at ieee dot org Assigned: sniper (profile)
Status: Closed Package: Compile Failure
PHP Version: 5.0.4, 4.3.11 OS: Solaris 2.9 Sparc
Private report: No CVE-ID: None
 [2005-05-13 00:12 UTC] terry dot gill at ieee dot org
Description:
------------
After running ./configure it hangs after apprently detecting OS version. On debugging I have found that the version of ~/build/shtools (yes, I know its supposed to be portable ;-/ ) will not run on Solaris 9. Downloading, locally building, and replacing the shtool binary resolves this problem.

Reproduce code:
---------------
See description

Expected result:
----------------
See description

Actual result:
--------------
See description

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-05-13 09:58 UTC] sniper@php.net
What version of shtool worked for you? The latest? (IIRC, it's 2.0.0 or something like that..)

 [2005-05-13 10:17 UTC] terry dot gill at ieee dot org
Yep 2.0.1. 

Incidentally the ./configure will also try and use the Solaris 
native version of 'lex' if it finds it first. Really need to 
ensure it finds 'flex' instead (reorder $PATH).
 [2005-05-30 14:59 UTC] sniper@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

shtool is now 2.0.1 in all branches. Other issues will only be fixed in HEAD. (5.1-dev)
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Apr 25 12:01:25 2019 UTC