php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32662 A few acuted letters don't recongnized
Submitted: 2005-04-11 02:04 UTC Modified: 2005-04-11 02:06 UTC
From: aeoris at gmail dot com Assigned:
Status: Not a bug Package: *Languages/Translation
PHP Version: 5.0.4 OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: aeoris at gmail dot com
New email:
PHP Version: OS:

 

 [2005-04-11 02:04 UTC] aeoris at gmail dot com
Description:
------------
PHP don't recognize letters like "acuted R" (in fact any acutted letter distinct from [aeiouy]) as "letters".

Reproduce code:
---------------
<?php
var_dump(ctype_alpha('???'));
var_dump(ctype_alpha('&#341;&#378;&#347;'));

var_dump(preg_match('/[a-z]/iU', '???'));
var_dump(preg_match('/[a-z]/iU', '&#341;&#378;&#347;'));
?>

Expected result:
----------------
bool(true) bool(true) int(1) int(1)

Actual result:
--------------
bool(false) bool(false) int(0) int(0) 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-04-11 02:06 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Mon Nov 19 13:01:26 2018 UTC