php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #32463 mhash implementation of Tiger incorrect?
Submitted: 2005-03-26 14:51 UTC Modified: 2005-03-29 00:39 UTC
From: Keamos at gmail dot com Assigned: sas (profile)
Status: Not a bug Package: mhash related
PHP Version: 4.3.10 OS: Windows XP SP2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Keamos at gmail dot com
New email:
PHP Version: OS:

 

 [2005-03-26 14:51 UTC] Keamos at gmail dot com
Description:
------------
Mhash fails the Tiger test vectors found at http://www.cs.technion.ac.il/~biham/Reports/Tiger/test-vectors-nessie-format.dat



Reproduce code:
---------------
Since the reproduce code is more than twenty lines, find it at http://pastebin.ca/8273


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-03-26 18:03 UTC] derick@php.net
Assigning to Sascha, the maintainer of this extension.
 [2005-03-28 23:32 UTC] jay@php.net
This isn't really a bug, it's more of a different  
implementation/interpretation of the Tiger algorithm. The  
test vectors provided on the Tiger homepage provide the  
output hash in little endian, while the testtiger  
reference implementation at the site outputs the hash in  
big endian. Both outputs are correct, I guess, it's just  
the ordering of the bytes that changes.   
  
I'll leave the bug status as is so Sascha can see it and 
give a more definitive anwser than I can, but I don't 
think it's a bug per se. 
 [2005-03-29 00:39 UTC] sniper@php.net
..
 [2013-12-29 03:03 UTC] klondike+php at klondike dot es
Was pointed to this bug when discussing tiger implementations in PHP.

The paper defining tiger at http://www.cs.technion.ac.il/~biham/Reports/Tiger/tiger.ps clearly states the operations are little endian at the beggining of section 3.

IIRC the last versions of the test code in the reference implementation (against which I run freetiger's tests) are aware of this,
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jan 25 20:01:26 2020 UTC