php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31645 apache_lookup_uri prevents further headers from being sent
Submitted: 2005-01-21 19:25 UTC Modified: 2005-01-24 12:50 UTC
From: john at jelsoft dot com Assigned: jorton (profile)
Status: Closed Package: Apache2 related
PHP Version: 4CVS, 5CVS (2005-01-22) OS: *
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: john at jelsoft dot com
New email:
PHP Version: OS:

 

 [2005-01-21 19:25 UTC] john at jelsoft dot com
Description:
------------
Any calls to the header() function after apache_lookup_uri() is called are not processed properly, so that the headers are not sent.

Running 4.3.11-dev, build date Jan 16 2005 16:25:34

Save the following in test.php:

Reproduce code:
---------------
<?php

header( "X-John: test1" );
apache_lookup_uri( 'test.php' );
header( "X-John2: test2" );

echo "hello";

?>

Expected result:
----------------
The header X-John2: test2 to be sent.

Actual result:
--------------
It's not sent, while X-John: test is sent.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-22 01:12 UTC] sniper@php.net
What Apache SAPI are you using?

 [2005-01-22 12:20 UTC] john at jelsoft dot com
From my phpinfo, from the 'Loaded modules' section of apache2handler, it has sapi_apache2. Also listed in the modules section is worker. PHP's server API is reported as Apache 2.0 Handler. Is that the information you're after?
Thanks!
 [2005-01-22 14:54 UTC] sniper@php.net
This bug was caused by this fix:
----------------------------
revision 1.16
date: 2005/01/11 14:01:32;  author: jorton;  state: Exp;  lines: +6 -1
Fixed bug #30446 - virtual() includes files out of sequence,
work around 2.0 subrequest/internal redirect issue.
----------------------------

 [2005-01-24 12:50 UTC] jorton@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

Ah, thanks, my bad.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Sep 29 17:05:53 2022 UTC