php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31520 Cannot instantiate COM object under Windows 2003 Server
Submitted: 2005-01-12 17:14 UTC Modified: 2005-01-13 16:57 UTC
From: khoukaz at web dot de Assigned:
Status: Not a bug Package: COM related
PHP Version: 4.3.9/5.0.3 OS: Windows 2003 Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: khoukaz at web dot de
New email:
PHP Version: OS:

 

 [2005-01-12 17:14 UTC] khoukaz at web dot de
Description:
------------
I'm not able to instantiate an object of my COM interface under Windows 2003 Server. I'm using the following code:

$obj = new COM(" <ProgID> ");

Under all other windows oporationg system it works fine, but not with Windows 2003 Server.

The error message is:

Warning: (null)(): Unable to obtain IDispatch interface for CLSID {C9E9F131-B9B5-4779-8267-D67B50EEBC20}: The server process could not be started because the configured identity is incorrect. Check the username and password. in c:\program files\apache group\apache\htdocs\test.php on line 7

Surprinsingly $shell= &new COM('WScript.Shell') for example makes no problems. So what is wrong with my COM interface?

I'm using PHP with apache 1.3.26 as a module.

Thanks in advance
Chris




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2005-01-13 09:11 UTC] khoukaz at web dot de
No, it's the same behaviour. The only difference is that the request takes some seconds now. Afterwards the error "The page cannot be displayed" appears in the browser. In the error.log file there's an entry with the error described below (Unable to obtain IDispatch interface for CLSID ...).

Chris
 [2005-01-13 13:23 UTC] khoukaz at web dot de
I tested it with PHP 5.0.3 on Windows 2003 Server and it's the same error:

Fatal error: Uncaught exception 'com_exception' with message 'Failed to create COM object `<...>': The server process could not be started because the configured identity is incorrect. Check the username and password. ' in c:\program files\apache group\Apache\htdocs\test.php:7 Stack trace: #0 c:\program files\apache group\Apache\htdocs\test.php(7): com->com('<...>') #1 {main} thrown in c:\program files\apache group\Apache\htdocs\test.php on line 7

So it really seems to be a bug in conjunction with Windows 2003 Server.

Chris
 [2005-01-13 15:35 UTC] khoukaz at web dot de
One more hint:
If i use dcomcnfg on my Windows 2003 Server to specify the corresponding application to run on another computer (Windows XP Prof), everything works fine. Unfortunately i cannot use this configuration...

Any idea?

Chris
 [2005-01-13 16:57 UTC] wez@php.net
You need to set up the access permissions/identity correctly.
This is not a PHP bug.
Consult the Microsoft Knowledge-base for help on this issue.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Dec 09 06:03:45 2022 UTC