php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #31129 new zend_strtod.c won't compile
Submitted: 2004-12-16 17:20 UTC Modified: 2004-12-21 05:53 UTC
Votes:7
Avg. Score:4.4 ± 0.7
Reproduced:6 of 6 (100.0%)
Same Version:3 (50.0%)
Same OS:1 (16.7%)
From: long+phpbugs at kestrel dot cc dot ku dot edu Assigned: derick
Status: Not a bug Package: Compile Failure
PHP Version: 4.3.10 OS: Tru64 4.0F
Private report: No CVE-ID:
 [2004-12-16 17:20 UTC] long+phpbugs at kestrel dot cc dot ku dot edu
Description:
------------
Here was my configure line:
LD_LIBRARY_PATH=/usr/local/ldap/lib \
CFLAGS='-O2 -std1 -ifo -taso' \
CXXFLAGS='-std1 -O2 -ifo -taso' \
CC='cc' \
CXX='cxx' \
'./configure' \
'--with-openssl' \
'--enable-bcmath' \
'--with-ndbm' \
'--with-dbm' \
'--enable-dbase' \
'--enable-filepro' \
'--enable-ftp' \
'--with-gd' \
'--with-ttf' \
'--with-java=/usr/opt/java141' \
'--with-mysql' \
'--with-oci8' \
'--with-oracle' \
'--enable-shmop' \
'--enable-sockets' \
'--enable-sysvsem' \
'--enable-sysvshm' \
'--enable-wddx' \
'--enable-dba=shared' \
'--enable-calendar' \
'--enable-exif' \
'--enable-discard-path' \
'--enable-dbx' \
'--enable-ctype' \
'--with-hyperwave' \
'--enable-mailparse' \
'--enable-mbstring' \
'--enable-mbstr-enc-trans' \
'--enable-memory-limit' \
'--with-ldap=/usr/local/ldap' \
'--with-inifile' \
'--with-flatfile' \
'--enable-dio' \
'--enable-sysvmsg' \
'--with-zlib' \
'--with-zlib-dir=/usr/local' \
'--with-jpeg-dir=/usr/local' \
'--with-png-dir=/usr/local' \
'--with-cdb=shared'

Here's where the compile fails:
cc  -IZend/ -I/homeb/long/src/php-4.3.10/Zend/ -DPHP_ATOM_INC -I/homeb/long/src/php-4.3.10/include -I/homeb/long/src/php-4.3.10/main -I/homeb/long/src/php-4.3.10 -I/homeb/long/src/php-4.3.10/Zend -I/usr/local/ssl/include -I/usr/local/include -I/usr/local/ldap/include -I/homeb/long/src/php-4.3.10/ext/mbstring/mbregex -I/homeb/long/src/php-4.3.10/ext/mbstring/libmbfl -I/homeb/long/src/php-4.3.10/ext/mbstring/libmbfl/mbfl -I/homeb/oracle/u01/app/oracle/product/817/rdbms/public -I/homeb/oracle/u01/app/oracle/product/817/rdbms/demo -I/homeb/long/src/php-4.3.10/ext/xml/expat  -I/homeb/long/src/php-4.3.10/TSRM  -O2 -std1 -ifo -taso  -c /homeb/long/src/php-4.3.10/Zend/zend_strtod.c -o Zend/zend_strtod.o  && echo > Zend/zend_strtod.lo
cc: Error: /homeb/long/src/php-4.3.10/Zend/zend_strtod.c, line 233: Missing ";". (nosemi)
Exactly one of IEEE_LITTLE_ENDIAN IEEE_BIG_ENDIAN, VAX, or
--------^

I also got the failure with php4-STABLE-200412152330


Reproduce code:
---------------
n/a

Expected result:
----------------
I expect the code to compile :-)

Actual result:
--------------
Compile fails.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-12-16 17:52 UTC] derick@php.net
Please grant me an account on the machine so that I can debug it. Feel free to mail that to my personal email address.
 [2004-12-16 18:30 UTC] long+phpbugs at kestrel dot cc dot ku dot edu
There is a good chance my sys admins won't allow me to give you an account on the Tru64 system.  Bjorn: do you think it is more likely you could get derick an account on the AIX system?
 [2004-12-16 18:58 UTC] long+phpbugs at kestrel dot cc dot ku dot edu
Ok, I lied.  It looks like it shouldn't be a problem to get you an account on the Tru64 box.  Details to follow.
 [2004-12-16 23:58 UTC] pkwarren at gmail dot com
I think the tests in that file should be for __sparc, not __sparc__. GCC defines both, but the Sun compiler only defines __sparc. Maybe the best solution for other platforms would be to use the WORDS_BIGENDIAN macro defined in php_config.h.
 [2004-12-21 05:53 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

There are enough reports about this already. And is fixed in CVS already too.

 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 23 07:02:14 2014 UTC