php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30180 PHP_NORMAL_READ and socket_read() error
Submitted: 2004-09-21 16:17 UTC Modified: 2004-09-22 00:05 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: tracid at zappmobile dot ro Assigned:
Status: Not a bug Package: Sockets related
PHP Version: 4.3.8 OS: Windows XP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tracid at zappmobile dot ro
New email:
PHP Version: OS:

 

 [2004-09-21 16:17 UTC] tracid at zappmobile dot ro
Description:
------------
Hello.

At the socket_read() function if you specify PHP_NORMAL_READ, it results in an error:
socket_read() failed: reason: Incorrect function.

It was already reported almost a year ago, but no fix since then...

Take care


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-09-22 00:05 UTC] derick@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Dup of #21409
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Apr 02 23:01:23 2020 UTC