php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #30023 image header problem
Submitted: 2004-09-08 10:45 UTC Modified: 2004-09-08 10:49 UTC
From: r dot h dot zeelenberg at bravo-informatisering dot nl Assigned:
Status: Not a bug Package: *Graphics related
PHP Version: 4.3.9RC2 OS: redhat
Private report: No CVE-ID: None
 [2004-09-08 10:45 UTC] r dot h dot zeelenberg at bravo-informatisering dot nl
Description:
------------
Proble with image header and reproducable situation. Also at different sites.

No able to show image after include of an empty file. I mean an include files thats only has only an declaration inside and NO OUTPUT OR SPACES...

How to reproduce the error:

php file get_test.php

This should place an image on the screen in verboden.php there should
be some checks but i've wiped them out for clearification. So
verboden.php is :

<?php
$documentroot=$_SERVER['DOCUMENT_ROOT'];
?>

get_test.php is :

<?php
$documentroot=$_SERVER['DOCUMENT_ROOT'];

#include($documentroot.'/verboden.php');

$afbeelding_file=$documentroot.'/images/geen_afbeelding_1.jpg';

header("Content-type: image/jpg");
$current_file=ImageCreateFromJPEG($afbeelding_file);
ImageJPEG ($current_file);
ImageDestroy($current_file);
?>

Attention! This works only!!! when i comment out the include for
verboden.php
I think this is very strange... Firefox is saying there is something
wrong with the image.. IE6 will try to download it.

Ronald


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-09-08 10:49 UTC] derick@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Duplicate of #30005
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Aug 20 00:01:27 2019 UTC