php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #29384 bcpow crashes apache (PHP 5.0.0)
Submitted: 2004-07-26 09:29 UTC Modified: 2004-07-28 03:24 UTC
From: suzanne at smkelly dot com Assigned:
Status: Closed Package: BC math related
PHP Version: 5.0.0 OS: NT4 sp6a
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: suzanne at smkelly dot com
New email:
PHP Version: OS:

 

 [2004-07-26 09:29 UTC] suzanne at smkelly dot com
Description:
------------
the bcpow example in the manual crashes apache 2.0.44 (using php5apache2.dll)

apache crashes with access violation

not unique to manual example
other uses of bcpow do the same thing

using php.ini-recommended, with just a few changes, namely:

display_errors = On
display_startup_errors = On
log_errors = Off
extension_dir = "E:\php5.0.0\ext\"
extension=php_mysql.dll
sendmail_from = info@smkelly.com

bcpow works ok with PHP 4.3.0, same computer, same web server.

this is a stable server that has been running for a long time


Reproduce code:
---------------
echo bcpow(4.2, 3, 2); // 74.08

Expected result:
----------------
display 74.08

Actual result:
--------------
apache/php crashes

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-07-27 14:36 UTC] tony2001@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php5-win32-latest.zip

Could you also try to run the same code with PHP-CLI?
I can't reproduce it witn under Win2k.
 [2004-07-27 20:39 UTC] suzanne at smkelly dot com
The snapshot of 2004-07-27 seems to work just fine.
 [2004-07-28 03:24 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Mon Dec 17 09:01:25 2018 UTC