php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28772 No input file specified.
Submitted: 2004-06-14 15:29 UTC Modified: 2004-06-29 18:57 UTC
From: pieter at amazed dot nl Assigned:
Status: Not a bug Package: iPlanet related
PHP Version: 4.3.7 OS: win nt 4
Private report: No CVE-ID: None
 [2004-06-14 15:29 UTC] pieter at amazed dot nl
Description:
------------
I recently installed the latest php 437 win 32 version

after associating  works fine test.php with cmd

want to work under netscape 3.6x enterprise
shellcgi

all i get is No input file specified


Reproduce code:
---------------
no input file specified


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-06-14 15:45 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

.
 [2004-06-22 00:47 UTC] jaoshar at yahoo dot fr
No, it is a bug. I use PHP v4.3.5 and it works fine in cmd, but returns the unremovable "No input file specified" with Apache (2.0.48 or 1.3.39). 
I've been months on this problem, read all the support/discussion places, but it seems there's no way out of this "problem".
My personal conclusion is that PHP guys intended to put such a bug in the windows binary (maybe to support products like Sokkit). 
I stopped trying. When it will be solved, I'll be back to PHP ;o), but learnd lots of things with Perl in the meanwhile !
 [2004-06-29 18:05 UTC] pieter at amazed dot nl
Hai ther it is not a bug in the first place
it is a bug in the webpublishing part of the server eg 3.63
I removed webpublishing function agent of then occurred the following: http server would not start i looked into the event viewer got this message: cannot find function: agent_name_trans  because with webpublishing on agents are on
but with webpublishing off agents go off too! andwhat i not could find before i found in obj.conf   agent_name_trans still in obj conf so I removed it first made a copy of obj.conf orig  and edited the thing. removed restarted the server when something wrong in obj.conf server never starts!
reloaded the file in servermanager and applied it
test.php in browser and voila works!!!
eg you should never use webpublishing because of severe
attack problems and the server crashes this was another problem i had with this thing saw this morning in eventviewer an attacker coming up with posts and finally with PROPFIND this time the server won from this attacker
found his adress and will attack this one legaly
cheers Pieter
 [2004-06-29 18:10 UTC] pieter at amazed dot nl
Hai there it is not a bug in the first place
it is a bug in the webpublishing part of the server eg 3.63
I removed webpublishing function agent of then occurred the following: http server would not start i looked into the event viewer got this message: cannot find function: agent_name_trans  because with webpublishing on agents are on
but with webpublishing off agents go off too! andwhat i not could find before i found in obj.conf   agent_name_trans still in obj conf so I removed it first made a copy of obj.conf orig  and edited the thing. removed restarted the server when something wrong in obj.conf server never starts!
reloaded the file in servermanager and applied it
test.php in browser and voila works!!!
cheers Pieter
 [2004-06-29 18:57 UTC] derick@php.net
No bug -> bogus
 [2004-08-12 06:40 UTC] mike at hotmail dot com
I'm having the same error with php5 and iis6. I've tried  
<?php phpinfo(); ?> and echo"hello world"; - i get this: 
No input file specified.
 [2004-08-21 00:12 UTC] flyfishMT69 at hotmail dot com
Same problem with PHP5.01, IIS5.1
 [2004-08-29 07:44 UTC] jay3963109 at yahoo dot com
For php5 + windows + IIS5, the documentation optionally recommends setting doc_root = C:\inetpub in the php.ini file. I tried this but got the "no input file specified" error. 

I fixed it on my machine by setting doc_root = C:\inetpub\wwwroot (or to whichever local path that I use for a home directory in my IIS settings). Maybe this happens to other web servers also -- try making sure that doc_root in php.ini matches the mapped home directory of your web server. [Don't forget to restart the web server after changing the php.ini file.]
 [2004-09-27 11:23 UTC] j dot celle at laposte dot net
Setting the doc_root cannot be a solution as there can be (and usually 'there are') more than one directory hoding many virtual servers on the same machine.
 [2004-10-23 09:51 UTC] kronius at gmail dot com
doc_root can only be a temporary solution.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Apr 23 02:01:25 2019 UTC