php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28460 zlib_output_compression On keepalive connections linger
Submitted: 2004-05-20 21:09 UTC Modified: 2005-01-07 01:00 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: pixl at 7pt dot net Assigned:
Status: No Feedback Package: Zlib related
PHP Version: 4.3.6 OS: Linux, Redhat, 2.4.21-9.0.3.ELs
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2004-05-20 21:09 UTC] pixl at 7pt dot net
Description:
------------
PHP 4.3.6
Apache 2 (prefork)

When using zlib_output_compression = On, with vBulletin Version 3.0.0 Internet Explorer and Mozilla Firefox does not show that the page has completed loading, until the keepalive timer expires (15 seconds in my config). Doing test with ethereal I see this.

with apachebench it works correcly
ab -n 2 -k -H "Accept-Encoding: gzip" http://forums.anabolicreview.com/
after the html is pulled the client sends a [FIN] packet and the server terminates the connection.

with Mozilla FireFox .8, the client pulls the page and images in about .2 seconds, then sits in globe spinning mode (little animation goes in the corner) for 15 seconds. At 15 seconds the server sends a [FIN-ACK] packet the connection is closed and the client is no longer connected.

Internet Explorer 6 does exactly the same as mozilla.

This only occurs with zlib_output_compression =on, with zlib_output_compression = off OR the obgzhandler settings on this does not occur.

Most of the problem I have is a human one, users see that the animation in there browser is still going for 15 seconds and make complaints that the message board is going slow even when the page has loaded in under a second.

I have currenly turned zlib-compression off, and enabled gzip compression in vbulletins settings (im assuming using ob_gzhandler in the php) and compression is working fine, I've just read in enough documentation that zlib_output_compression is the recommended way to run php.

If you need certian detailed information please ask, I'll reneable zilb on the server and reproduce the problem.

Thank You, Peter

apache2 configuration
CFLAGS="-O2 -mcpu=pentium4 -march=pentium4"; export CFLAGS
"./configure" \
"--prefix=/usr/local/apache" \
"--enable-shared=max" \
"$@"

php 4.3.6 configuration

'./configure' '--with-apxs2=/usr/local/httpd/bin/apxs' '--with-config-file-path=/usr/local/httpd' '--disable-debug' '--disable-ipv6' '--disable-display-source' '--disable-cgi' '--with-zlib' '--with-gettext' '--with-bz2' '--with-gd' '--enable-gd-native-ttf' '--enable-memory-limit' '--enable-sysvshm' '--enable-sysvsem' '--enable-sysvmsg' '--enable-shared' '--with-freetype-dir=/usr' '--with-mysql=/usr' '--with-tiff-dir=/usr' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' 




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-05-21 00:08 UTC] scottmacvicar at ntlworld dot com
Does the same problem occur with apache 1?
 [2004-12-30 04:01 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

Also respond to the feedback request above, about Apache 1..

 [2005-01-07 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 18 17:01:27 2019 UTC