php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28153 Unable to add encoding to XML Declaration
Submitted: 2004-04-26 10:40 UTC Modified: 2004-05-07 14:46 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: silvein at php dot x256 dot com Assigned:
Status: Wont fix Package: DOM XML related
PHP Version: 4.3.6 OS: Linux 2.4.25_pre7 SMP
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2004-04-26 10:40 UTC] silvein at php dot x256 dot com
Description:
------------
When using domxml_new_doc() the only allowed argument is the "varsion" attribute for the XML declaration.  I am unable to find a way to add an "encoding" attribute.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-04-26 10:51 UTC] silvein at php dot x256 dot com
When using domxml_new_doc() the only allowed argument is the "version" attribute for the XML declaration.  I am unable to find a way to add an "encoding" attribute.
 [2004-05-07 14:46 UTC] rrichards@php.net
This is not going to be added to domxml. You either need to use the domxml_open_xxx functions and specify the encoding there or pass the encoding when dumping the data like: $doc->dump_mem(TRUE, "ISO-8859-1"); Since encoding isnt needed until output, you should probably just pass the encoding in the dump functions during output.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Apr 26 07:01:25 2019 UTC