php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #28037 The PDF extension does not load
Submitted: 2004-04-17 18:20 UTC Modified: 2004-04-18 00:59 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: egarcia at egm dot as Assigned:
Status: Not a bug Package: *PDF functions
PHP Version: 4.3.6 OS: Windows XP Professional
Private report: No CVE-ID: None
 [2004-04-17 18:20 UTC] egarcia at egm dot as
Description:
------------
I install the new 4.3.6 version, and I have a trouble when the php_pdf.dll extension is loaded.

PHP Warning:  Unknown(): Unable to load dynamic library 'c:\PHP\extensions\php_pdf.dll' - The specified module could not be found.
 in Unknown on line 0

1. The php_pdf.dll exists in that directory.
2. There is another extensions loaded.
3. All works Ok with the 4.3.6RC1 version and the same PHP.ini
4. If I disable this extension, all works Ok.
5. A simple <?php phpinfo(); ?> generates the error.

Regards,


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2004-04-17 18:29 UTC] egarcia at egm dot as
May be this can help:

PHP 4.3.6
php_pdf.dll 72.0 KB (73,728 bytes)
Wednesday, April 14, 2004, 5:34:54 PM

4.3.6RC1
php_pdf.dll 528 KB (540,672 bytes)
Thursday, April 01, 2004, 11:27:30 PM

If I replace the current DLL with the OLDER, it WORKS.
PDF Support  enabled  
PDFlib GmbH Version  4.0.2  
Revision  $Revision: 1.112.2.9 $
 [2004-04-18 00:59 UTC] derick@php.net
You can find the needed pdflib.dll in the dll directory of the distribution. Not a bug.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon May 27 03:01:26 2019 UTC