php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #25556 mail function looses characters
Submitted: 2003-09-16 08:03 UTC Modified: 2003-09-16 09:45 UTC
From: te at mxu dot de Assigned:
Status: Not a bug Package: Mail related
PHP Version: 4.3.3 OS: Win32 (w2k)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: te at mxu dot de
New email:
PHP Version: OS:

 

 [2003-09-16 08:03 UTC] te at mxu dot de
Description:
------------
hello,

i encountered a problem when sending mails longer than approx. 1K. mail (and imap_mail) seem to loose characters every 1k. this happend after upgrading to 4.3.3 (from 4.0.?or so)

greetings from munich

thorsten engel

Reproduce code:
---------------
$body = '';

for ($i=0; $i<100; $i++)
{
	for ($j=0; $j<76; $j++)
		$body .= 'a';
	$body.="\r\n";
}

mail ("te@mxu.de","subj",$body);
imap_mail ("te@mxu.de","subjimap",$body);

Expected result:
----------------
aaaaa (76 chars per line)
aaaaa
aaaaa
aaaaa
aaaaa
aaaaa

Actual result:
--------------
aaaaa (some lines only have 75 chars!!)
aaaaa
aaaa
aaaaa
aaaaa

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-09-16 09:45 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

Try search the bug database BEFORE you submit any report.
This was fixed long time ago.

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Jan 28 14:05:52 2023 UTC