php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #24227 Cannot Connect to Ingres II Database
Submitted: 2003-06-17 12:55 UTC Modified: 2003-06-18 18:15 UTC
From: jr07766 at hotmail dot com Assigned:
Status: Not a bug Package: *Database Functions
PHP Version: 4.3.2 OS: IRIX 6.5.19f
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jr07766 at hotmail dot com
New email:
PHP Version: OS:

 

 [2003-06-17 12:55 UTC] jr07766 at hotmail dot com
Description:
------------
I have successfully compiled and installed php 4.3.2 with Ingres II support using Apache 2.0.46. I cannot get the ingres_connect function to work. I would greatly appreciate any help in identifying why this is happening and what I need to do to fix the problem

These are the messages I am getting when I try to connect to the ingres database using:

$link = ingres_connect("$host" . "::" . "$database", "$user", "$password")
    or trigger_error("Could not connect to Ingres database '" . $database . "'",E_USER_ERROR);

Warning: ingres_connect(): Ingres II: Server or API error : Unable to authenticate client's user ID. in /usr/freeware/apache2/htdocs/ing/ingpgtableinfo.php
on line 36

Warning: ingres_connect(): Ingres II: SQLSTATE : 08004 in /usr/freeware/apache2/htdocs/ing/ingpgtableinfo.php on line 36

Warning: ingres_connect(): Ingres II: Unable to connect to database (192.168.1.103::arsr4) in /usr/freeware/apache2/htdocs/ing/ingpgtableinfo.php on line
36

Fatal error: Could not connect to Ingres database 'arsr4' in /usr/freeware/apache2/htdocs/ing/ingpgtableinfo.php on line 37




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-18 14:20 UTC] sniper@php.net
This is a bug database, not support forum.

 [2003-06-18 16:07 UTC] jr07766 at hotmail dot com
I successfully compiled and installed php. How do I or you know whether this is a bug or not. I can't find anybody that has successfully used php with ingres.
 [2003-06-18 16:08 UTC] jr07766 at hotmail dot com
status = open
 [2003-06-18 18:15 UTC] sniper@php.net
As long as you don't say it worked in PHP 4.3.1 but not in 4.3.2, we have to say it's not a bug. That thing hasn't changed at all for couple of months at least..

So please, ask elsewhere for support, here you won't find
any support on _using_ PHP.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 04 18:01:26 2020 UTC