php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #24173 ability and get dup headers
Submitted: 2003-06-13 08:16 UTC Modified: 2012-09-10 03:10 UTC
From: Xuefer at 21cn dot com Assigned:
Status: Duplicate Package: Apache related
PHP Version: 4.3.2 OS: all
Private report: No CVE-ID: None
 [2003-06-13 08:16 UTC] Xuefer at 21cn dot com
Description:
------------
current apache_response_headers() is not able to return multi headers, e.g.: 2 Set-Cookie, only 1 returned, because it return array, which store only unique key

so i suggest that, add apache_response_headers(true) to return array like this:
array(
0=> "Content-Type: ..",
1=> "Set-Cookie: ...",
2=> "Set-Cookie: ...",
3=> "Set-Cookie: ...",
);


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-01-01 01:46 UTC] jani@php.net
-Package: Feature/Change Request +Package: Apache related
 [2012-09-09 12:10 UTC] space at wechall dot net
This can be closed as duplicate of Bug #44744.
 [2012-09-10 03:10 UTC] aharvey@php.net
Agreed. Thanks for pointing it out!
 [2012-09-10 03:10 UTC] aharvey@php.net
-Status: Open +Status: Duplicate
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jun 24 11:01:26 2019 UTC