php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23802 segmentation fault
Submitted: 2003-05-25 14:41 UTC Modified: 2003-06-02 17:27 UTC
From: vittorio at vitsoft dot bz Assigned:
Status: No Feedback Package: PEAR related
PHP Version: 4.3.1 OS: Linux
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2003-05-25 14:41 UTC] vittorio at vitsoft dot bz
I install Suse 8.2 with php 4.3.1 the I download some PEAR modules neede for run imp WebMail.

When I try to use the Log modules with a version greater that 1.6.3 I have always segmentation fault in my /var/log/httpd/errorlog file.

Using version 1.6.3 solve all the problem.
PHP compiling options :
PHP Version 4.3.1

   System Linux mail 2.4.20-4GB #1 Mon Mar 17 17:54:44 UTC 2003 i686
   Build Date Mar 17 2003 17:33:31
   Configure Command './configure' '--prefix=/usr/share'
   '--datadir=/usr/share/php' '--bindir=/usr/bin' '--libdir=/usr/share' '--includedir=/usr/include' '--with-_lib=lib' '--with-config-file-path=/etc' '--with-exec-dir=/usr/lib/php/bin' '--disable-debug' '--enable-bcmath' '--enable-calendar' '--enable-ctype' '--enable-dbase' '--enable-discard-path' '--enable-exif' '--enable-filepro' '--enable-force-cgi-redirect'
'--enable-ftp' '--enable-gd-imgstrttf' '--enable-gd-native-ttf' '--enable-inline-optimization' '--enable-magic-quotes' '--enable-mbstr-enc-trans' '--enable-mbstring' '--enable-mbregex'
'--enable-memory-limit' '--enable-safe-mode' '--enable-shmop' '--enable-sigchild' '--enable-sysvsem' '--enable-sysvshm' '--enable-track-vars' '--enable-trans-sid' '--enable-versioning' '--enable-wddx' '--enable-yp' '--with-bz2'  '--with-dom=/usr/include/libxml2' '--with-ftp' '--with-gdbm'
'--with-gettext' '--with-gmp' '--with-imap=yes' '--with-iodbc' '--with-jpeg-dir=/usr' '--with-ldap=yes' '--with-mcal=/usr' '--with-mcrypt' '--with-mysql=/usr' '--with-ndbm' '--with-pgsql=/usr' '--with-png-dir=/usr' '--with-readline' '--with-snmp' '--with-t1lib'
'--with-tiff-dir=/usr' '--with-ttf' '--with-freetype-dir=yes' '--with-xml' '--with-xpm-dir=/usr/X11R6' '--with-zlib=yes'
'--with-qtdom=/usr/lib/qt3' '--with-gd' '--with-openssl' '--with-curl' '--with-imap-ssl' '--enable-xslt' '--with-xslt-sablot' '--with-iconv' '--with-mm' 'i586-suse-linux'

Server API CGI
   Virtual Directory Support disabled
   Configuration File (php.ini) Path /etc/php.ini
   PHP API 20020918
   PHP Extension 20020429
   Zend Extension 20021010
   Debug Build no
   Thread Safety disabled
   Registered PHP Streams php, http, ftp, https, ftps, compress.bzip2,
   compress.zlib
   Zend logo This program makes use of the Zend Scripting Language
   Engine:
   Zend Engine v1.3.0, Copyright (c) 1998-2002 Zend Technologies


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-05-25 15:12 UTC] nicos@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2003-06-02 17:27 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.

..and reduce your configure options to bare minimum that you REALLY need. And check ./configure --help for info about some of those options..for example --enable-versioning is not needed..

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Jun 26 06:01:26 2019 UTC