php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23412 Invalid Oracle version (8.05) detection
Submitted: 2003-04-29 09:38 UTC Modified: 2003-04-30 02:29 UTC
From: g dot noel at symphonieonline dot com Assigned:
Status: Wont fix Package: *Configuration Issues
PHP Version: 4CVS-2003-04-29 (stable) OS: Linux Debian
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2003-04-29 09:38 UTC] g dot noel at symphonieonline dot com
Configure failed detecting Oracle Version (8.0.5.0.0) because, in this version of Oracle the unix.rgs file is not "well formatted". Indeed, the "version" field is the 5th and not the 6th : 

    OCI8_VERSION=`grep '"ocommon"' $OCI8_DIR/orainst/unix.rgs | sed 's/  */:/g' | cut -d: -f 6 | cut -c 2-4`

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-29 10:27 UTC] sniper@php.net
You can always edit that file.


 [2003-04-30 02:29 UTC] g dot noel at symphonieonline dot com
Editing the file !? It's okay for me... But why not apply any simple patch, like this one :

# diff -u configure configure-fix
--- configure   2003-04-30 08:29:51.000000000 +0200
+++ configure-fix       2003-04-30 08:55:24.000000000 +0200
@@ -50861,10 +50861,7 @@

   echo $ac_n "checking Oracle version""... $ac_c" 1>&6
 echo "configure:50864: checking Oracle version" >&5
-  if test -s "$OCI8_DIR/orainst/unix.rgs"; then
-    OCI8_VERSION=`grep '"ocommon"' $OCI8_DIR/orainst/unix.rgs | sed 's/  */:/g' | cut -d: -f 6 | cut -c 2-4`
-    test -z "$OCI8_VERSION" && OCI8_VERSION=7.3
-  elif test -f $OCI8_DIR/lib/libclntsh.$SHLIB_SUFFIX_NAME.9.0; then
+  if test -f $OCI8_DIR/lib/libclntsh.$SHLIB_SUFFIX_NAME.9.0; then
     OCI8_VERSION=9.0
   elif test -f $OCI8_DIR/lib/libclntsh.$SHLIB_SUFFIX_NAME.8.0; then
     OCI8_VERSION=8.1
@@ -50877,7 +50874,12 @@
       OCI8_VERSION=8.1
     fi
   else
-    { echo "configure: error: Oracle-OCI8 needed libraries not found" 1>&2; exit 1; }
+    if test -s "$OCI8_DIR/orainst/unix.rgs"; then
+      OCI8_VERSION=`grep '"ocommon"' $OCI8_DIR/orainst/unix.rgs | sed 's/  */:/g' | cut -d: -f 6 | cut -c 2-4`
+      test -z "$OCI8_VERSION" && OCI8_VERSION=7.3
+    else
+      { echo "configure: error: Oracle-OCI8 needed libraries not found" 1>&2; exit 1; }
+    fi
   fi
   echo "$ac_t""$OCI8_VERSION" 1>&6
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue May 21 02:01:26 2019 UTC