php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23238 strnatcmp, strnatcasecmp not locale aware
Submitted: 2003-04-16 05:01 UTC Modified: 2003-04-16 16:02 UTC
From: mikael at chl dot chalmers dot se Assigned:
Status: Not a bug Package: *Languages/Translation
PHP Version: 4.3.0 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mikael at chl dot chalmers dot se
New email:
PHP Version: OS:

 

 [2003-04-16 05:01 UTC] mikael at chl dot chalmers dot se
Resubmission of http://bugs.php.net/bug.php?id=19795 since it has been closed down but still exists in 4.3.0, haven't tested in any newer versions.

Sorting strings containing national characters such as the swedish ??? etc places them in the wrong order when using the natural cmp functions (strnatcmp, strnatcasecmt) and possibly the same is true for the array functions (natcmp, natcasecmp). The regular string functions (strcmp, strcasecmp) works correctly though.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-16 16:02 UTC] moriyoshi@php.net
Please do not register an entry that is identical to the older one. Add further comments here => bug #19795.

 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Mon Nov 19 11:01:25 2018 UTC