php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #23061 fockopen resource leaking
Submitted: 2003-04-05 05:21 UTC Modified: 2003-04-06 03:11 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: nico at osict dot com Assigned:
Status: Closed Package: Sockets related
PHP Version: 4.3.1 OS: Windows XP
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: nico at osict dot com
New email:
PHP Version: OS:

 

 [2003-04-05 05:21 UTC] nico at osict dot com
When fockopen is used on a non working IP address (e.g. to test if some server is currently running) it seems to cause resource leaking. Even if fclose is used properly, and the php page has finished. This behaviour does not occur with working IP addresses.

This can be verified with windows task manager by looking in the handles column of apache.exe.

When repeated many times (>10000) Windows XP will collapse because applications will no longer be able to open IP ports.

I am using the windows binary on http://www.php.net/downloads.php with Apache/1.3.24.

Nico de Vries (nico@osict.com)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-04-06 03:11 UTC] nico at osict dot com
I tried http://snaps.php.net/win32/php4-win32-STABLE-latest.zip as sugested by wez@php.net and have not been able to reproduce the problem with that version. Thank you for looking into it.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 10 01:05:46 2022 UTC