php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #22247 The UTF BOM is sent out
Submitted: 2003-02-17 07:03 UTC Modified: 2003-02-17 07:43 UTC
Votes:1
Avg. Score:2.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: muranyia at iqc dot hu Assigned:
Status: Not a bug Package: Output Control
PHP Version: 4.2.3 OS:
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: muranyia at iqc dot hu
New email:
PHP Version: OS:

 

 [2003-02-17 07:03 UTC] muranyia at iqc dot hu
When an UTF BOM (Byte Order Mark) is saved in a script, it is not recogised by PHP, instead it is interpreted as text, and it is sent out with the output (and prevents the user from issuing Header() commands, btw.)
Info on UTF BOM: http://www.unicode.org/unicode/faq/utf_bom.html#22

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-02-17 07:43 UTC] moriyoshi@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

dupe of bug #22108
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Oct 21 15:01:27 2019 UTC