|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21986 Apache won't start with compiled with OpenSSl 0.9.7
Submitted: 2003-01-31 13:02 UTC Modified: 2003-04-22 11:42 UTC
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: dev5 at es11 dot com Assigned: iliaa (profile)
Status: Closed Package: OpenSSL related
PHP Version: 4.3.1-dev(feb4 18:30) OS: FreeBSD 4.6.2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Bug Type:
From: dev5 at es11 dot com
New email:
PHP Version: OS:


 [2003-01-31 13:02 UTC] dev5 at es11 dot com
Apache 1.3.27 with modssl 2.8.12:
OpenSSL 0.9.7
Returns an error something like:
"Undefined symbol OpenSSL_..._noconf"

php4.3.0 configured with the following line: 
'./configure' '--with-mysql=/usr/local/mysql' '--with-apxs=/usr/local/apache/bin/apxs' '--enable-track-vars' '--with-pdflib' '--with-gd' '--with-jpeg-dir=/usr/local/lib' '--enable-gd-native-ttf' '--with-png-dir=/usr/local/lib' '--with-xpm-dir=/usr/local/lib' '--with-freetype-dir=/usr/local/lib' '--with-ttf' '--with-tiff-dir' '--with-zlib' '--enable-ftp' '--enable-cli' '--with-pspell' --with-openssl

This bug is similar to bug #21947

it seems that there might be a problem with openSSL 0.9.7 and php 4.3.0 together
make test returned 2 FAILS (previously none with openssl 0.9.6e)

1. Fail on error handling
2. Fail on Open SSL create keys (or something like that)

Thanks for help and support



Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-31 16:16 UTC]
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at
In case this was a documentation problem, the fix will show up soon at

In case this was a website problem, the change will show
up on the site and on the mirror sites in short time.
Thank you for the report, and for helping us make PHP better.

 [2003-02-04 12:48 UTC] dev5 at es11 dot com
The problem still appears even in CVS 
tested on freeshly installed FreeBSD 4.7 with OpenSSL successfully patched for FreeBSD

make test still Fails in OpenSSL on creating private keys
 [2003-02-04 13:18 UTC] dev5 at es11 dot com
issue is no longer a problem on FreeBSD 4.6.2

however bug #21600 came up 
Thank you for fixing :)
 [2003-02-04 13:58 UTC] dev5 at es11 dot com
Apache still returns an error:
Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/ into server: /usr/local/apache/libexec/ Undefined symbol "OPENSSL_add_all_algorithms_noconf"
/usr/local/apache/bin/apachectl startssl: httpd could not be started

Apache 1.3.27
OpenSSL 0.9.7
modssl 2.8.12
php 4.3.1-dev (feb 4 18:30)

make test (php) did not FAIL on any OpenSSL functions, though.

I'm confused. Please help. 

Thank you 
 [2003-02-04 14:21 UTC]
Could it be that your Apache & PHP are compiled against different versions of OpenSSL and that is the cause the problem?
 [2003-02-04 16:41 UTC] dev5 at es11 dot com
I reinstalled apache and made sure the OpenSSL is indeed 0.9.7 

same effect... it won't start.

I will contact the openssl, mod_ssl and apache developers and try to resolve this issue

Thanks again 

 [2003-04-20 02:29 UTC] gil at disatnik dot com

I have the same problem here,

FreeBSD 4.6,

I have recently recompiled apache & mod_ssl against openssl 0.9.7b they both work fine, but when I recompiled php (I had it linked against 0.9.7a before, and it run without any problem although the apache was linked to 0.9.7b...) I get the same error...

I am using the latest ports dir (cvsup'd 10 hours ago...)

Apache 1.3.27
openssl 0.9.7b
php 4.3.1
 [2003-04-22 11:42 UTC] dev5 at es11 dot com
My resolution to this problem was reverting to the 0.9.6 series (non-engine version). I thi9nk the latest is 0.9.6i when compiling php. You can install multiple versions of openssl on your machine. I haven't tried recompiling php with 0.9.7 series. I suspect that problems arise from combining the engine and non-engine releases together in openssl 0.9.7. If you're going to try and recompile PHP I suggest backing up in youre libexec dir under apache.

good luck

 [2003-04-29 13:35 UTC] vieth at N-O-extravaganz-S-P-A-M dot net
I got the same error: 
OS: SuSE 8.1
Apache 2.0.45

I tried different combinations
Apache 2.0.45 openssl-0.9.6j php-4.3.1
Apache 1.3.27 openssl-0.9.6j php-4.3.1
Apache 1.3.27 openssl-0.9.6j php4-STABLE-200304281730

At least i compiled
Apache 2.0.45 openssl-0.9.6i php-4.3.1 
and all works fine
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Apr 20 17:01:23 2021 UTC