php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21796 Compile fails on AIX 4.3.3
Submitted: 2003-01-21 09:32 UTC Modified: 2003-01-21 14:38 UTC
From: ed at ebonmists dot com Assigned:
Status: Not a bug Package: Compile Failure
PHP Version: 4.3.0 OS: AIX 4.3.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ed at ebonmists dot com
New email:
PHP Version: OS:

 

 [2003-01-21 09:32 UTC] ed at ebonmists dot com
A few minor warnings with configure, then configure ends with:

| about the implications of having register_globals set to on, and   |
| avoid using it if possible.                                        |
+--------------------------------------------------------------------+

./config.status[1739]: 6: bad file unit number
./config.status[1740]: 6: bad file unit number

Didnt seem too bad, so I went with the compile, and it fails with:

        cc -I/root/php/php-4.3.0/ext/mysql/libmysql -Iext/mysql/ -I/root/php/php-4.3.0/ext/mysql/ -DPHP_ATOM_INC -I/root/php/php-4.3.0/include -I/root/php/php-4.3.0/main -I/root/php/php-4.3.0 -I/root/php/php-4.3.0/Zend -I/root/php/php-4.3.0/ext/xml/expat  -I/root/php/php-4.3.0/TSRM  -g  -c /root/php/php-4.3.0/ext/mysql/libmysql/my_tempnam.c -o ext/mysql/libmysql/my_tempnam.o  && echo > ext/mysql/libmysql/my_tempnam.lo
"/root/php/php-4.3.0/ext/mysql/libmysql/my_tempnam.c", line 99.5: 1506-025 (S) Operand must be a modifiable lvalue.
"/root/php/php-4.3.0/ext/mysql/libmysql/my_tempnam.c", line 105.3: 1506-025 (S) Operand must be a modifiable lvalue.
make: 1254-004 The error code from the last command is 1.

I saw another bug here with the same exact compile failure, but in a different file, and it was fixed. Hopefully this will be as easy.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-21 10:16 UTC] ed at ebonmists dot com
Same problem, same line number.
 [2003-01-21 14:38 UTC] iliaa@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

Dup of bug #21284.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 18 16:01:27 2020 UTC