php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21677 GetImageSize nolonger works
Submitted: 2003-01-15 23:26 UTC Modified: 2003-01-15 23:28 UTC
From: moderator at blackpeeps dot com Assigned:
Status: Not a bug Package: GetImageSize related
PHP Version: 4.3.0 OS: RAQ4-Latest Patches/Apache 1.3.2
Private report: No CVE-ID: None
 [2003-01-15 23:26 UTC] moderator at blackpeeps dot com
Recently upgraded to PHP 4.3.0 with GD-2.0.1
Scripts worked fine before upgrade. 
After 4.3.0 upgrade, Sometimes GetImageSize works (returns probper width and height variables) and sometimes it does not (my resize functions are defaulting to 1x2 pixels) 

At first I thought the problem was isolated to jpgs created with prior version PHP 4.1.2 and GD-2.0.0 and imagecreatefromjpeg function.  Then I noticed that there are photos were an image tag (imagecreatefromjpeg) was not used. So the problem is only occuring with certain files.)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-15 23:28 UTC] philip@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

#21676
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jul 16 15:01:26 2019 UTC