php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21629 very strange bug happens only once in a while
Submitted: 2003-01-14 02:54 UTC Modified: 2003-02-04 05:20 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: aric at nsa dot co dot il Assigned:
Status: Not a bug Package: *Directory/Filesystem functions
PHP Version: 4.3.0 OS: Red Hat Linux 7.2 (Enigma)
Private report: No CVE-ID: None
 [2003-01-14 02:54 UTC] aric at nsa dot co dot il
I have scanned the bug reports here for 30 minutes and found some reports that had some resemblence but none were the same at all.

I am running Apache 1.3.27 with PHP 4.3.0, but the problem existed in 4.2.3 (I upgraded to 4.3.0 trying to fix the issue).

Every once in a while, and unrelated to the server load, various code reports inclusion problems. For example:

Warning: main(includes/classes/language.php) [function.main]: failed to create stream: No such file or directory in /sites/shop.harim.co.il/htdocs/includes/boxes/languages.php on line 24

.
.  <- (Additional errors as a result of the failed inclusion)
.

The file exists, 100%. The script works 99% of the times. If I change all includes to be absolute, it works fine all the time, but with relative file paths, once in a while, and sometimes, does not happen for hours, it will give this error.

What is making this bug so difficult for me to track, is indeed that it only happens once every few hours. Sometimes, it would have a 'bad attack' where it would happen consecutively (several page refreshes with the same problem), but 5 to 10 seconds later, it will not happen for yet another few hours.

This is killing me. Anyone else here has this problem? My phpinfo() output can be found here:

http://www.nsa.co.il/phpinfo.php

Thanks for any help,

        Aric

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-14 19:14 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

You didn't search that well, there is already a report about this. And even if it doesn't seem to be same, it really is.

 [2003-01-15 01:49 UTC] aric at nsa dot co dot il
That's not very helpful is it? Where is that bug? What was the resolution?

I found 5 or 6 resembling bugs, but they were either closed without a resolution, or were not exactly the same (they had to do with misconfiguration).

Also, this is NOT a Bogus bug! At most, it is a duplicate.

    Aric
 [2003-01-15 03:17 UTC] sniper@php.net
The include_path in your phpinfo.php output is a bit strange:  include_path  0  .:./

What do you have it set as in your php.ini?

(in /usr/local/lib/php.ini)


 [2003-01-16 19:51 UTC] skaag@php.net
Some kind person forwarded me to bug number 21310. I have already SEEN this bug as stated before. This is not the same problem!

As the subject says, Inclusion works, both absolute and relative. It works well for 5 hours, then one include will fail, will work again very well for 2 more hours, then, again some relative include failes!

This is NOT a constant behavior, because if it was, I'm not such an idiot that I wouldn't be able to track it down! My trouble is that it only happens once every few hours, and is unrelated to anything. I made sure the kernel has enough file descriptors, and made sure there is enough space left on the device, and CPU load is never over 0.2!

This is definitely a bug, and even if it is not a bug, the error reporting for it is definitely obscure and insucificient.

The include path was indeed set to "0" for some reason, and I have changed it in my php.ini to ".:./". This has not helped much.

I performed a super-fresh compilation of 4.3.0, without relying on any external software/extension.

Whoever manages to shed some light on this will get my most sincere gratitude, as it is a heavy burden on the soul to have such a problem.

Thanks again,

       Aric

 [2003-01-17 20:10 UTC] sniper@php.net
Are you able to reproduce this on any OTHER machine?


 [2003-01-18 14:36 UTC] aric at nsa dot co dot il
No, I can not reproduce this on any other machine.

Perhaps one of the libraries on the machine is creating all these problems. On the other hand, I really have no tools to find which one, because the occurence is so rare (a few times in 24 hours, but not rare enough for my client to complain, and not even rare enough for my own standards).

I am going to reformat this box and install Debian on it, and use the latest stable version of php available on the debian stable update channel.

Should you have any suggestions, or even want to access the box to check some stuff, I am available on this email, and also online on ICQ 104495.

Thanks,

      Aric
 [2003-01-19 23:47 UTC] sniper@php.net
Please let us know if the reinstalling fixes this problem.

 [2003-02-04 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over 2 weeks, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2003-02-04 03:08 UTC] aric at nsa dot co dot il
Well I have completely re-installed Linux on that box with Debian 3.0, did a dist-upgrade, and installed apache + php. It works beautifully now. I still wish I knew what it was, but right now it is no longer important.

Thanks for the time.

     Aric
 [2003-02-04 05:20 UTC] sniper@php.net
Not really PHP bug -> bogus. 
 [2004-03-25 03:22 UTC] phpbug21629 at pech dot cz
I'm able to reproduce it. First I thought it's a xbithack bug (25753), so I repaired Fedora PHP distribution and reinstalled PHP. But it doesn't work. Sometimes script returns no output. Tell me, what you need more to send and I will do so.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Aug 24 01:01:27 2019 UTC