php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21517 when open COM ADODB connection php crash
Submitted: 2003-01-08 07:44 UTC Modified: 2003-01-25 11:55 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: andrusso at libero dot it Assigned:
Status: Not a bug Package: COM related
PHP Version: 4.3.0 OS: Windows 98
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: andrusso at libero dot it
New email:
PHP Version: OS:

 

 [2003-01-08 07:44 UTC] andrusso at libero dot it
With this new version 4.3.0 if I open an ADODB connection with an Access database php crash.
Windows '98, Xitami Web Server.

$dbc = new COM("ADODB.Connection") or die("Cannot start ADO");
$connstr = "DRIVER={Microsoft Access Driver (*.mdb)};";
$connstr .= "DBQ='c:\test.mdb';uid=;pwd=;";
$dbc->open($connstr);

With php 4.2.3 the script run well.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-01-08 23:38 UTC] andrusso at libero dot it
Of course c:\\temp\test.mdb will be an valid access database.
 [2003-01-25 11:55 UTC] phanto@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.

#21378
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 10 23:05:51 2022 UTC