php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2124 Parser duplicates, corrupts <DIV> tag
Submitted: 1999-08-22 16:42 UTC Modified: 1999-08-22 16:59 UTC
From: webhead at web-feats dot com Assigned:
Status: Closed Package: Parser error
PHP Version: Earlier? Upgrade first! OS: BSDI / Win95
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: webhead at web-feats dot com
New email:
PHP Version: OS:

 

 [1999-08-22 16:42 UTC] webhead at web-feats dot com
Both this statement:
<DIV style="position: absolute; left: 0px; top: 15px">

And this statement:
<div style="position: absolute; left: 0px; top: 15px">

Produce the following output after going through PHP3 preprocessor on both my ISP's UNIX server and my desktop Win95 port of PHP3:

<DIV style="position: absolute; left: 0px; top: 15px"><DIV Ttyle="position: absolute; left: 0px; top: 15px">

The closing </DIV> tag is produced only once, and the resulting HTML code works anyway in Navigator 4.6.

On my desktop machine I am running php-3.0.6-win32.
ISP is running php-3.0b3 on BSDI BSD/OS 2.1 Kernel #11.

Sorry to bother you if this has already been corrected.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-08-22 16:59 UTC] zeev at cvs dot php dot net
The option 'Earlier?  Upgrade first!' isn't supposed to be a
valid choice...  We can definitely not support such old
versions.  Upgrade first and see if the problem still occurs,
if it does - resubmit the bug report.

Thanks,

Zeev

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu Jul 18 02:01:29 2024 UTC