php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21216 phpize passes --no-verify to ltconfig without specifying host
Submitted: 2002-12-27 11:25 UTC Modified: 2002-12-27 12:03 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: jsheets at shadotech dot com Assigned:
Status: Wont fix Package: *Configuration Issues
PHP Version: 4.3.0 OS: FreeBSD 4.7-STABLE
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-12-27 11:25 UTC] jsheets at shadotech dot com
The phpize program creates a configure file that executes ltconfig with --no-verify but does not specify the host, FreeBSD ltconfig (libtool 1.3.4) requires the host be specified when the --no-verify parameter is passed, this results in the configure failing.  When libtool 1.4 is installed the problem is resolved however 1.3.4 is what is in FreeBSD ports.

This has been verified to be true with PHP 4.3.0 release on FreeBSD 4.7-STABLE with at least the curl, mhash and bz2 extensions.

My configuration is as follows:

AMD Athlon 1 GHZ CPU (686 class)
FreeBSD 4.7
256 MB RAM
Apache 1.3.27
PHP 4.3.0
Libtool: (GNU libtool) 1.3.4-freebsd-ports

My PHP configuration line is:  './configure' '--with-apxs=/usr/local/sbin/apxs' '--with-mcrypt' '--with-mhash' '--with-zlib' '--with-bz2' '--with-interbase' '--with-pdflib' '--with-gd' '--with-pgsql' '--with-mysql' '--enable-ftp'


The output from the failed configure script is:

loading cache /dev/null within ltconfig
ltconfig: you must specify a host type if you use `--no-verify'
Try `ltconfig --help' for more information.
configure: error: libtool configure fail

I manually installed libtool 1.4 and the problem went away, however the version of libtool in the FreeBSD ports collection is 1.3.4 so it is what most FreeBSD users will have installed.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-27 12:03 UTC] derick@php.net
PHP requires libtool 1.4 anyway, so the best thing would be to mail the FreeBSD maintainers again to update their software. 

Derick
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Aug 18 23:01:26 2019 UTC