php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20435 $_POST not filled with enctype="multipart/form-data"
Submitted: 2002-11-14 17:59 UTC Modified: 2002-11-15 01:33 UTC
From: chregu@php.net Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4CVS-2002-11-14 OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: chregu@php.net
New email:
PHP Version: OS:

 

 [2002-11-14 17:59 UTC] chregu@php.net
Following form does not work in PHP_4_3 from CVS.

<html><head><title></title></head>
<body>
<?php print_r($_POST);?>
<form name="Master" action="./post.php" method="post" 
enctype="multipart/form-data" >
<input type="test" name="hello" value="world"> 
<input type="submit">
</form>
<?php phpinfo();?>
</body>
</html>


enctype="application/x-www-form-urlencoded" does work.

maybe it has something to do with the recent changes in the POST area.

chregu

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-14 18:00 UTC] chregu@php.net
"does not work" = $_POST is empty...

chregu
 [2002-11-14 18:16 UTC] moriyoshi@php.net
I can't reproduce this problem even with mbstring...

  <input type="test" name="hello" value="world"> 

Is this a typo for either [type="hidden"] or [type="text"]?
 [2002-11-15 01:15 UTC] chregu@php.net
I found the source of the error. 

If "always_populate_raw_post_data" is set to On (and enctype="multipart/form-data"), then $_POST is empty. If Off, then it has the correct values .

In 4.2 it did work with always_... = On. I know hartmut was working on this stuff and I'm not sure if this is a real bug, or if it's a known "bug". But at least, there should be some warning somewhere about that.

chregu
 [2002-11-15 01:33 UTC] sniper@php.net
Yes, hartmut fixed it already couple of days ago.

 [2004-04-02 10:30 UTC] robotech at mixmail dot com
I have already "always_populate_raw_post_data" in Off and I still having problem with $POST when I use "enctye='multipart/form-data'"
Also I tried "always_populate_raw_post_data" in On and I had the same problem.

Could someone give a solution at last to this problem.

Thank you
Axl Laruse
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 25 09:01:24 2020 UTC