php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20357 make fails with the snmp extension
Submitted: 2002-11-11 06:43 UTC Modified: 2002-11-12 11:22 UTC
From: alietss at yahoo dot com Assigned:
Status: Closed Package: SNMP related
PHP Version: 4CVS-2002-11-11 OS: Linux RedHat 8.0
Private report: No CVE-ID: None
 [2002-11-11 06:43 UTC] alietss at yahoo dot com
Hi everybody and thank's for a great job, I'm starting to migrate to php-4.3.0, to do that I'm building RPMS for RedHat8.0, to test it, I found that when you include --with-snmp the make program fails with this error...

/usr/src/redhat/BUILD/php-4.3.0/ext/snmp/snmp.c: In function `zif_snmp_get_quick_print':
/usr/src/redhat/BUILD/php-4.3.0/ext/snmp/snmp.c:461: `NETSNMP_DS_LIBRARY_ID' undeclared (first use in this function)
/usr/src/redhat/BUILD/php-4.3.0/ext/snmp/snmp.c:461: (Each undeclared identifier is reported only once
/usr/src/redhat/BUILD/php-4.3.0/ext/snmp/snmp.c:461: for each function it appears in.)
/usr/src/redhat/BUILD/php-4.3.0/ext/snmp/snmp.c:461: `NETSNMP_DS_LIB_QUICK_PRINT' undeclared (first use in this function)
/usr/src/redhat/BUILD/php-4.3.0/ext/snmp/snmp.c: In function `zif_snmp_set_quick_print':
/usr/src/redhat/BUILD/php-4.3.0/ext/snmp/snmp.c:480: `NETSNMP_DS_LIBRARY_ID' undeclared (first use in this function)
/usr/src/redhat/BUILD/php-4.3.0/ext/snmp/snmp.c:480: `NETSNMP_DS_LIB_QUICK_PRINT' undeclared (first use in this function)
make: *** [ext/snmp/snmp.lo] Error 1

                           I hope it helps, bye Aliet

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-11 09:59 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip
 [2002-11-11 10:00 UTC] sniper@php.net
And what snmp library do you have installed? net-snmp? And what version? Are you sure you don't have both ucd-snmp and net-snmp installed?

 [2002-11-11 10:44 UTC] alietss at yahoo dot com
Hi, yes I'm sure, I'm just using net-snmp version 5.0.1-6 wich comes with RedHat8.0, with the past php-4.2.4dev everything was fine...
 [2002-11-11 18:07 UTC] sniper@php.net
Apparently the net-snmp people changed that somewhere between 5.0.1 and 5.0.6. Just get 5.0.6 and it works.

 [2002-11-11 23:05 UTC] alietss at yahoo dot com
ok, this is really a pain, I update to 5.0.6 and now I obtain this
In file included from /usr/include/net-snmp/library/snmp_impl.h:39,
                 from /usr/include/ucd-snmp/snmp_impl.h:3,
                 from /usr/src/redhat/BUILD/php-4.3.0/ext/snmp/snmp.c:86:
/usr/include/net-snmp/types.h:11:2: #error "Please include <net-snmp/net-snmp-config.h> before this file"
In file included from /usr/src/redhat/BUILD/php-4.3.0/ext/snmp/snmp.c:90:
/usr/include/ucd-snmp/version.h:5: initializer element is not constant
make: *** [ext/snmp/snmp.lo] Error 1
 [2002-11-12 06:08 UTC] sniper@php.net
Heh, now you definately do have ucd-snmp and net-snmp installed..at least the headers. You really should clean that mess and try again. PHP compiles fine with both, as long as you don't have them under same prefix..

 [2002-11-12 11:22 UTC] alietss at yahoo dot com
Well, definitly PHP-4.3.0 can't be built in RedHat 8.0 with their packages by defalut, you should first update sharutils from rawhide distribution to 4.2.1, elfutils to 0.54, and rebuild all this packages in redhat 8.0, after that rebuilt the net-snmp 5.0.6-7 from rawhide in RedHat 8.0, update then your Redhat 8.0 and then just in this way you can build php-4.3.0 in RH 8.0. You also has to update curl to 7.10.2 if you don't do this you can't. After doing all this finally I built the rpms for RedHat8.0. Bye Aliet
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Apr 20 14:01:25 2019 UTC