php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19906 "pear package" produces broken .tgz archive
Submitted: 2002-10-14 12:41 UTC Modified: 2002-10-15 11:12 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: sebastian@php.net Assigned: wez (profile)
Status: Closed Package: Filesystem function related
PHP Version: 4.3.0-pre1 OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: sebastian@php.net
New email:
PHP Version: OS:

 

 [2002-10-14 12:41 UTC] sebastian@php.net
"pear package" in the XML_Transformer directory creates a
broken tgz archive.

The archive seems to have right filesize, but when I try to
"tar xvfz" it, I only get a "package.xml" file from it.

Could this be related to current streams issues?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-14 12:42 UTC] sebastian@php.net
Verified by Wez. Assigned to Wez, since it's most likely
streams related.

 [2002-10-14 16:17 UTC] wez@php.net
It's a problem with zlib streams.
Workaround for the moment:

pear package -Z
gzip packagename.tar

 [2002-10-14 16:19 UTC] wez@php.net
Also, Archive_Tar no longer needs to do this:

if ($this->compress)
   gzputs($this->file, $data);
else
   fputs($this->file, $data);

A simple fputs($this->file, $data) will do the job.
And what's with all the @'s??
Does it really need them?  It makes finding errors
almost impossible :-/


 [2002-10-15 11:12 UTC] wez@php.net
Fixed in CVS.
(That was a hard problem to find).
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Nov 26 16:05:52 2022 UTC