php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19400 Apache crash with w32api_register_function
Submitted: 2002-09-14 03:57 UTC Modified: 2003-01-02 18:43 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: michel dot sentenac at libertysurf dot fr Assigned:
Status: No Feedback Package: Reproducible crash
PHP Version: 4.2.0 OS: Win98 Win2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: michel dot sentenac at libertysurf dot fr
New email:
PHP Version: OS:

 

 [2002-09-14 03:57 UTC] michel dot sentenac at libertysurf dot fr
Hi,
I am using w32api_register_function to call windows dll to access a medicine database.
Php version is 4.2.0 and Apache 1.3.24 (in fact easyphp 1.6).

Each time I call W32api_register_fuction Apache crash and is automaticly reload and the php script run well, but running it again make the same Apache crash.

This problem occure even with standard window dll such as user32.dll.

What could be wrong?
Thanks in advance for your help
Michel

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-01 18:03 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2002-10-17 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over 2 weeks, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2002-12-06 07:38 UTC] michel dot sentenac at libertysurf dot fr
Get same problem with all different version of PHP issue from snaps.php.net.

I know that w32api is experimental.But I get this problem for several month.A few time agon J.Moore tells me a new version is going to be released.
Please could you tell me if w32api is really supported and if a new version is available.
Please Help
 [2002-12-19 23:13 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2003-01-02 18:43 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Oct 03 04:05:53 2022 UTC