php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19311 header function with location not working
Submitted: 2002-09-09 07:22 UTC Modified: 2002-09-09 07:24 UTC
From: marpas9756 at mail dot drq dot pl Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 4.2.3 OS: Win2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: marpas9756 at mail dot drq dot pl
New email:
PHP Version: OS:

 

 [2002-09-09 07:22 UTC] marpas9756 at mail dot drq dot pl
I try simple redirection script
<? 
header("Location: http://".$_SERVER['HTTP_HOST'].dirname($_SERVER['PHP_SELF'])."/sample.htm");
exit;
?>
but my browser displaing only blank white window. Apache version is 2.0.40 with php working as module.
When I try to execute this script if php is working as cgi application everything is going ok.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-09 07:24 UTC] sander@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Jan 28 20:03:45 2023 UTC